summaryrefslogtreecommitdiff
path: root/dev-ruby/introspection
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/introspection
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/introspection')
-rw-r--r--dev-ruby/introspection/Manifest5
-rw-r--r--dev-ruby/introspection/introspection-0.0.3.ebuild26
-rw-r--r--dev-ruby/introspection/introspection-0.0.4.ebuild28
-rw-r--r--dev-ruby/introspection/metadata.xml8
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-ruby/introspection/Manifest b/dev-ruby/introspection/Manifest
new file mode 100644
index 000000000000..aaf7e0691ba5
--- /dev/null
+++ b/dev-ruby/introspection/Manifest
@@ -0,0 +1,5 @@
+DIST introspection-0.0.3.gem 9216 BLAKE2B ecc019bdace30aaf0a1357fbdaf56f19722b9ada0e61b335ffadf1ceac3340a664245d177a8ffe9caace9cab1b81d203578f8b914165309be17b6d6734966055 SHA512 423722f402a8a5cb5f415c498cf754a2b5084b0a89ada48b982a97e3951d9af4bcd675d5dc4a2eacdd0673bf08facaba845e767e3e248e0a8ec922eddbc53c37
+DIST introspection-0.0.4.gem 9216 BLAKE2B c97279576a60dfd74453d16a6eb0885326dad18748bd182fe3b5c2a73121553cd3ea66690841df6554fd105e50f5f6df075afb94795b94dbd7caf4615ca67764 SHA512 c228827ac9d8a82a104e78daadf038c674cd464bf726fc3bd1efa82e9d9cab37f6ee909f578585e7846378f0b755ed4d60fa119fd699f6c40188ea2de4ac7084
+EBUILD introspection-0.0.3.ebuild 642 BLAKE2B fe9e420e8a8741735cbc5db7a39c5c624fc173675153ef56dc603147a33d3f0eeda65435fcdfdaef7ee33042f8c294c0cce0436087203b2c4ed751c852551fe0 SHA512 d0725e51a36ae20b5649c5c61e76457734a71c8512017336751a275a624c23a1b537dae60a6c7b509d8458e35205f6f1d1ef0d1860e54181f9789e6e4958a6bf
+EBUILD introspection-0.0.4.ebuild 671 BLAKE2B 26cc2e77805c8a4a4299da9288f01f0957a2870144beb79a4877fff19f45d5e31065ece3db747b85394a765e5004187facfc724553359b89b541cd2d62c71682 SHA512 403fcb81ec1aa8f77d6d9b57834b6cfc307c56bccce100f8b690a0c6189b3a668f79f0c172c7623e56cb2ac0c8a5a852363836cfc72c68631e348c918b7d636d
+MISC metadata.xml 247 BLAKE2B 7717702c51c35b2a20983332abc6218047b2b5036e6b4c09d3d58b4339e8f9e776879cd116cfda60d3bcf4188859993fb9f3f779aaf595f155d53e85288f3dcc SHA512 ea4c044637b751a2c28c6ac226121e74ef18196af4b594e60413fec907bbab29c6b0c7735c3f503485df16dcfb36ddb86038394d92e2cd18c8f04626628e9f09
diff --git a/dev-ruby/introspection/introspection-0.0.3.ebuild b/dev-ruby/introspection/introspection-0.0.3.ebuild
new file mode 100644
index 000000000000..a0f138a55afe
--- /dev/null
+++ b/dev-ruby/introspection/introspection-0.0.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+# No documentation task
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Dynamic inspection of the hierarchy of method definitions on a Ruby object"
+HOMEPAGE="http://jamesmead.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sparc x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/metaclass-0.0.1 >=dev-ruby/instantiator-0.0.3"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile test/test_helper.rb || die
+}
diff --git a/dev-ruby/introspection/introspection-0.0.4.ebuild b/dev-ruby/introspection/introspection-0.0.4.ebuild
new file mode 100644
index 000000000000..02cedee13c23
--- /dev/null
+++ b/dev-ruby/introspection/introspection-0.0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+# No documentation task
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Dynamic inspection of the hierarchy of method definitions on a Ruby object"
+HOMEPAGE="http://jamesmead.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~ppc ppc64 ~sparc x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/metaclass-0.0.1"
+
+ruby_add_bdepend "test? ( dev-ruby/blankslate )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile test/test_helper.rb || die
+}
diff --git a/dev-ruby/introspection/metadata.xml b/dev-ruby/introspection/metadata.xml
new file mode 100644
index 000000000000..28ab0c15f206
--- /dev/null
+++ b/dev-ruby/introspection/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+</maintainer>
+</pkgmetadata>