summaryrefslogtreecommitdiff
path: root/dev-ruby/immutable-ruby
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-15 13:38:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-15 13:38:09 +0100
commitdb70871b2044b9bfde346d6f4027dafb0a013c4c (patch)
tree34548aee54e5458d3754bd8c8f987acdb5ee444c /dev-ruby/immutable-ruby
parent1c382dc5dbc52576ac2300fee0498af8af44e7b4 (diff)
gentoo auto-resync : 15:06:2023 - 13:38:09
Diffstat (limited to 'dev-ruby/immutable-ruby')
-rw-r--r--dev-ruby/immutable-ruby/Manifest3
-rw-r--r--dev-ruby/immutable-ruby/immutable-ruby-0.1.0.ebuild33
-rw-r--r--dev-ruby/immutable-ruby/metadata.xml12
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-ruby/immutable-ruby/Manifest b/dev-ruby/immutable-ruby/Manifest
new file mode 100644
index 000000000000..dc47f283fcae
--- /dev/null
+++ b/dev-ruby/immutable-ruby/Manifest
@@ -0,0 +1,3 @@
+DIST immutable-ruby-0.1.0.tar.gz 134479 BLAKE2B c113ab9bf6b9accdc40eed351cc3177745e52926546d3c4c001786b47790b2c2eba97dfd0751000fd51ad11eb760039c82a2c6f0618776d87a460a16bfc1b9cf SHA512 3136884f791f0d9c1e460a848192723753f5c63f230faa2cec32445ea875392871d38de09222521fd78493397561a4dddbc61e9b020d5089d1c90694c46bde19
+EBUILD immutable-ruby-0.1.0.ebuild 840 BLAKE2B f293d92598142b020fc7e93b0b1a65b5b65785b533ce650f3fdce6b45829309002eb5e3a35306b0caf47f369dc7647fb0822708ab2f58d14b3bc04a8da67120c SHA512 ce9deba335d417fb349cee252a2cf207f586daaaacdcd0a1a784b243da975aa054f484f725adaccfb887b38d97360aec870677747d8cd9d5b9eee3e4ea3a4fbd
+MISC metadata.xml 414 BLAKE2B 571f839dc0ea21a932950fe77179a42e0cbe0f34e3d33173940036ec06a338c8aec667884d7d0ec0e55ef2deb52893789dc764b5ae38165d9a80c0380de9dde1 SHA512 c21a07f3af57ec3bf30fbca817de2aa0d9000db883baa33d0a0db1eff8c04dcab70f66a49512073d78d93d9ec48f7a8fced7dd59fb2ebbcc5f428c830238988c
diff --git a/dev-ruby/immutable-ruby/immutable-ruby-0.1.0.ebuild b/dev-ruby/immutable-ruby/immutable-ruby-0.1.0.ebuild
new file mode 100644
index 000000000000..6078251ff622
--- /dev/null
+++ b/dev-ruby/immutable-ruby/immutable-ruby-0.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_GEMSPEC="immutable-ruby.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+# Releases are not tagged upstream
+COMMIT=84dba7382284fe7e85816a65abf5c2fc9bbc089e
+
+inherit ruby-fakegem
+
+DESCRIPTION="Efficient, immutable, thread-safe collection classes for Ruby"
+HOMEPAGE="https://github.com/immutable-ruby/immutable-ruby"
+SRC_URI="https://github.com/immutable-ruby/immutable-ruby/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${PN}-${COMMIT}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/concurrent-ruby-1.1:1
+ dev-ruby/sorted_set:0
+"
+
+all_ruby_prepare() {
+ sed -i -e '/pry/ s:^:#:' spec/spec_helper.rb spec/lib/immutable/vector/insert_spec.rb || die
+}
diff --git a/dev-ruby/immutable-ruby/metadata.xml b/dev-ruby/immutable-ruby/metadata.xml
new file mode 100644
index 000000000000..061e7a1bb6bb
--- /dev/null
+++ b/dev-ruby/immutable-ruby/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">immutable-ruby/immutable-ruby</remote-id>
+ <remote-id type="rubygems">immutable-ruby</remote-id>
+ </upstream>
+</pkgmetadata>