summaryrefslogtreecommitdiff
path: root/dev-ruby/image_processing/image_processing-1.9.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /dev-ruby/image_processing/image_processing-1.9.3.ebuild
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'dev-ruby/image_processing/image_processing-1.9.3.ebuild')
-rw-r--r--dev-ruby/image_processing/image_processing-1.9.3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/image_processing/image_processing-1.9.3.ebuild b/dev-ruby/image_processing/image_processing-1.9.3.ebuild
new file mode 100644
index 000000000000..00324c0fa69c
--- /dev/null
+++ b/dev-ruby/image_processing/image_processing-1.9.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md doc/*.md"
+
+RUBY_FAKEGEM_GEMSPEC="image_processing.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="High-level image processing helper methods with libvips and ImageMagick"
+HOMEPAGE="https://github.com/janko/image_processing"
+SRC_URI="https://github.com/janko/image_processing/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/mini_magick-4.9.5:0
+"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/minitest-5.8:5
+ >=dev-ruby/minitest-hooks-1.4.2
+)"
+
+all_ruby_prepare() {
+ # Only support imagemagick for now since vips is not packaged
+ sed -i -e '/ruby-vips/ s:^:#:' ${RUBY_FAKEGEM_GEMSPEC} || die
+ rm -f test/{pipeline,vips}_test.rb || die
+ sed -i -e '/assert_dimensions/ s:^:#:' test/*_test.rb || die
+
+ # phash is not packaged
+ sed -i -e '/\(assert\|refute\)_similar/ s:^:#:' test/*_test.rb || die
+
+ sed -i -e '/\(bundler\|phashion\|vips\)/ s:^:#:' test/test_helper.rb || die
+}