summaryrefslogtreecommitdiff
path: root/dev-ruby/idn-ruby/idn-ruby-0.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
commit520a5b56dff7c24c9d42eafec142cb78b44f8e3e (patch)
treef562f705600dbd2292e97c0b4145787c2a8d1f97 /dev-ruby/idn-ruby/idn-ruby-0.1.0.ebuild
parent3811bc3072bf19e2be351d2c63f81532945c0f21 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'dev-ruby/idn-ruby/idn-ruby-0.1.0.ebuild')
-rw-r--r--dev-ruby/idn-ruby/idn-ruby-0.1.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/idn-ruby/idn-ruby-0.1.0.ebuild b/dev-ruby/idn-ruby/idn-ruby-0.1.0.ebuild
new file mode 100644
index 000000000000..994b0ebe8a97
--- /dev/null
+++ b/dev-ruby/idn-ruby/idn-ruby-0.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="LibIDN Ruby Bindings"
+HOMEPAGE="https://github.com/deepfryed/idn-ruby"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND+=" net-dns/libidn:0"
+DEPEND+=" net-dns/libidn:0"
+
+all_ruby_prepare() {
+ # Avoid UTF-8 tests since we cannot guarantee a UTF-8 environment
+ rm -f test/tc_Stringprep.rb || die
+}
+
+each_ruby_prepare() {
+ mkdir lib || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext
+ cp ext/idn.so lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/*.rb"].each{|f| require f}' || die
+}