summaryrefslogtreecommitdiff
path: root/dev-ruby/httpclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/httpclient
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/httpclient')
-rw-r--r--dev-ruby/httpclient/Manifest3
-rw-r--r--dev-ruby/httpclient/httpclient-2.8.3.ebuild64
-rw-r--r--dev-ruby/httpclient/metadata.xml11
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-ruby/httpclient/Manifest b/dev-ruby/httpclient/Manifest
new file mode 100644
index 000000000000..3dee4dffc70f
--- /dev/null
+++ b/dev-ruby/httpclient/Manifest
@@ -0,0 +1,3 @@
+DIST httpclient-2.8.3.tgz 464624 BLAKE2B ce8ed523a24acce219027a4f1985caf2b4dae29bdba038ca2397e5f4d4b36c90b35cedfb62faa7faf426c3ce8589906df7832968c81b64bc9100eff6f4fe9745 SHA512 b65b5adb97af069d7ff6b6f4cccd6a42c6d9c88b797e9495768fe1f36a6bd93defe50190edc201de5e39c4e306ba0bd17a8ff2f8eba4d636dacafa06c172967d
+EBUILD httpclient-2.8.3.ebuild 2000 BLAKE2B 14dbbd57bedd257e93603b3e53a62943d93a47ae622cfc09558842e20a0e593ec4a297f7c5b43feac8033a1f0461dec08d986be5ee11bd51d84d2c7b8957f900 SHA512 cc8a7ce3c3cdf4088fece7ee4a6cabedd84aefdcf6398bdc6359a9d75e9649d36c12027abe8c65db371bb7dcfd6c10183c67d96e5f438de8ad245a298e899fcb
+MISC metadata.xml 341 BLAKE2B 09a632c45802b3044056e60f69c99f2829bd710728ae4014de53ef83dc1e273a6e751a1d84e08195319ea207e8b62f11a1d055c96f6f161483a00746d6103cd4 SHA512 04d6c137c27403e7512feab47cd105f6cef456af315ec05b5204022eb9a8b7eda358f3ef4a19ff457770b3898c6395055880f5a162477f15d0948b148c902288
diff --git a/dev-ruby/httpclient/httpclient-2.8.3.ebuild b/dev-ruby/httpclient/httpclient-2.8.3.ebuild
new file mode 100644
index 000000000000..6927280d6904
--- /dev/null
+++ b/dev-ruby/httpclient/httpclient-2.8.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_TEST="-Ilib test"
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="httpclient.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="'httpclient' gives something like the functionality of libwww-perl (LWP) in Ruby"
+HOMEPAGE="https://github.com/nahi/httpclient"
+SRC_URI="https://github.com/nahi/httpclient/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="Ruby"
+SLOT="0"
+
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ppc ~ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "virtual/ruby-ssl"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
+ruby_add_bdepend "test? ( dev-ruby/test-unit dev-ruby/http-cookie )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[bB]undler/s:^:#:' Rakefile || die
+
+ # Fix documentation task
+ sed -i -e 's/README.txt/README.md/' Rakefile || die
+
+ # Remove mandatory CI reports since we don't need this for testing.
+ sed -i -e '/reporter/s:^:#:' Rakefile || die
+
+ # Remove mandatory simplecov dependency
+ sed -i -e '/[Ss]imple[Cc]ov/ s:^:#:' test/helper.rb || die
+
+ # Comment out test requiring network access that makes assumptions
+ # about the environment, bug 395155
+ sed -i -e '/test_async_error/,/^ end/ s:^:#:' test/test_httpclient.rb || die
+
+ # Skip tests using rack-ntlm which is not packaged. Weirdly these
+ # only fail on jruby.
+ rm test/test_auth.rb || die
+
+ # Skip test failing due to hard-coded expired certificate
+ sed -i -e '/test_verification_without_httpclient/,/^ end/ s:^:#:' test/test_ssl.rb || die
+
+ # Skip test depending on obsolete and vulnerable SSLv3
+ sed -i -e '/test_no_sslv3/,/^ end/ s:^:#:' test/test_ssl.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'gem "test-unit"; Dir["test/test_*.rb"].each{|f| require f}' || die
+}
diff --git a/dev-ruby/httpclient/metadata.xml b/dev-ruby/httpclient/metadata.xml
new file mode 100644
index 000000000000..26846ad431fa
--- /dev/null
+++ b/dev-ruby/httpclient/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">nahi/httpclient</remote-id>
+ </upstream>
+</pkgmetadata>