summaryrefslogtreecommitdiff
path: root/dev-ruby/httpclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-ruby/httpclient
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-ruby/httpclient')
-rw-r--r--dev-ruby/httpclient/Manifest3
-rw-r--r--dev-ruby/httpclient/httpclient-2.8.3-r1.ebuild78
-rw-r--r--dev-ruby/httpclient/httpclient-2.8.3.ebuild2
3 files changed, 81 insertions, 2 deletions
diff --git a/dev-ruby/httpclient/Manifest b/dev-ruby/httpclient/Manifest
index 133d0ad1da67..4629e0991d2d 100644
--- a/dev-ruby/httpclient/Manifest
+++ b/dev-ruby/httpclient/Manifest
@@ -1,3 +1,4 @@
DIST httpclient-2.8.3.tgz 464624 BLAKE2B ce8ed523a24acce219027a4f1985caf2b4dae29bdba038ca2397e5f4d4b36c90b35cedfb62faa7faf426c3ce8589906df7832968c81b64bc9100eff6f4fe9745 SHA512 b65b5adb97af069d7ff6b6f4cccd6a42c6d9c88b797e9495768fe1f36a6bd93defe50190edc201de5e39c4e306ba0bd17a8ff2f8eba4d636dacafa06c172967d
-EBUILD httpclient-2.8.3.ebuild 1969 BLAKE2B abb0da2b4338c47829d642a1a10e4c84b6093c890f5f2718bf264492dd73cc3623790a4ec109468dce9b3de2aa3fe8ff4d45719e92e70a1ca7194549a3310961 SHA512 bc84b1da002d33a060fe8348842e5bf2d2dd0cf728e03bbfb6a129d83a70232744cc6024a10d7a85405606457153a4bae0ad8c788db152ebc22b80c59d3a3aaa
+EBUILD httpclient-2.8.3-r1.ebuild 2733 BLAKE2B b2f688eb6f4fdb2794a3a8ee14da83d02d1e3cc77de9e4b5fa999ff918e3beb0d095ac27026be352d181010a6365cfb4f55f4ee10e2282e732ca2612842d4b6f SHA512 e21c465bafdd12ec37651adb865c78b90a0e2032185f303ae7e6e9d9745fd9476b2c94dd08371d2b0610c8fb027654ccabbabf0cdd878f8f80e5766149376d06
+EBUILD httpclient-2.8.3.ebuild 1969 BLAKE2B a10ed12b97cc24a02346b21fe2bfadaecc49085455193434d9885aec83de029e1a00aab57332ceb32061bbe483842fba7af1b62f6e39ee8286743774e5b32cc8 SHA512 7c41c093baf46568dffaa43f44cd8d2dc0e264fea00bd04b885586711ef6756a0647f93076f5e068b593fbbebd0559729be7f088d60f53bec1e88426dc49e4d4
MISC metadata.xml 342 BLAKE2B 357371edae972dc4bf17bef8a0ddf752bd81a3936a4ba6cc83ec7a253346e3d236bb0930fc71f14c1c42a486f3202bcd08352260aef38676f57b31f852dcca27 SHA512 3c3e6861463a129c5679658a044b956f1d8a4ad086c5fc77029037ad88b391af06cfbe26127127ae0b909d602c9a3b02929c48d7a26059ebd29e06c394d7b4c4
diff --git a/dev-ruby/httpclient/httpclient-2.8.3-r1.ebuild b/dev-ruby/httpclient/httpclient-2.8.3-r1.ebuild
new file mode 100644
index 000000000000..36a0fd386fbc
--- /dev/null
+++ b/dev-ruby/httpclient/httpclient-2.8.3-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_TASK_TEST="-Ilib test"
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="httpclient.gemspec"
+
+inherit ruby-fakegem eapi8-dosym
+
+DESCRIPTION="'httpclient' gives something like the functionality of libwww-perl (LWP) in Ruby"
+HOMEPAGE="https://github.com/nahi/httpclient"
+SRC_URI="https://github.com/nahi/httpclient/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="Ruby"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "virtual/ruby-ssl"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
+ruby_add_bdepend "test? ( dev-ruby/test-unit dev-ruby/http-cookie )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[bB]undler/s:^:#:' Rakefile || die
+
+ # Fix documentation task
+ sed -i -e 's/README.txt/README.md/' Rakefile || die
+
+ # Remove mandatory CI reports since we don't need this for testing.
+ sed -i -e '/reporter/s:^:#:' Rakefile || die
+
+ # Remove mandatory simplecov dependency
+ sed -i -e '/[Ss]imple[Cc]ov/ s:^:#:' test/helper.rb || die
+
+ # Comment out test requiring network access that makes assumptions
+ # about the environment, bug 395155
+ sed -i -e '/test_async_error/,/^ end/ s:^:#:' test/test_httpclient.rb || die
+
+ # Skip tests using rack-ntlm which is not packaged. Weirdly these
+ # only fail on jruby.
+ rm test/test_auth.rb || die
+
+ # Skip test failing due to hard-coded expired certificate
+ sed -i -e '/test_verification_without_httpclient/,/^ end/ s:^:#:' test/test_ssl.rb || die
+
+ # Skip test depending on obsolete and vulnerable SSLv3
+ sed -i -e '/test_no_sslv3/,/^ end/ s:^:#:' test/test_ssl.rb || die
+
+ # Do not use 11-year-old bundled certificates!
+ # fix this copy so it doesn't fail tests
+ ln -sf "${EPREFIX}"/etc/ssl/certs/ca-certificates.crt ./dist_key/cacerts.pem
+ ln -sf "${EPREFIX}"/etc/ssl/certs/ca-certificates.crt ./lib/httpclient/cacert.pem
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'gem "test-unit"; Dir["test/test_*.rb"].each{|f| require f}' || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+ # Do not use 11-year-old bundled certificates!
+ # fix this copy for production systems
+ # do not ship the cacert1024.pem at all anymore, nobody should use RSA1024 certs!
+ rm -f "${ED}/$(ruby_fakegem_gemsdir)/gems/${RUBY_FAKEGEM_NAME}-${RUBY_FAKEGEM_VERSION}/lib/httpclient/"{cacert.pem,cacert1024}.pem
+ dosym8 -r /etc/ssl/certs/ca-certificates.crt $(ruby_fakegem_gemsdir)/gems/${RUBY_FAKEGEM_NAME}-${RUBY_FAKEGEM_VERSION}/lib/httpclient/cacert.pem
+}
diff --git a/dev-ruby/httpclient/httpclient-2.8.3.ebuild b/dev-ruby/httpclient/httpclient-2.8.3.ebuild
index f5e7bf53b506..160c1d9af9dd 100644
--- a/dev-ruby/httpclient/httpclient-2.8.3.ebuild
+++ b/dev-ruby/httpclient/httpclient-2.8.3.ebuild
@@ -3,7 +3,7 @@
EAPI=5
-USE_RUBY="ruby25 ruby26 ruby27"
+USE_RUBY="ruby26 ruby27 ruby30"
RUBY_FAKEGEM_TASK_TEST="-Ilib test"
RUBY_FAKEGEM_TASK_DOC="doc"