summaryrefslogtreecommitdiff
path: root/dev-ruby/httpclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /dev-ruby/httpclient
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'dev-ruby/httpclient')
-rw-r--r--dev-ruby/httpclient/Manifest3
-rw-r--r--dev-ruby/httpclient/httpclient-2.8.3-r2.ebuild (renamed from dev-ruby/httpclient/httpclient-2.8.3-r1.ebuild)8
-rw-r--r--dev-ruby/httpclient/httpclient-2.8.3.ebuild64
3 files changed, 5 insertions, 70 deletions
diff --git a/dev-ruby/httpclient/Manifest b/dev-ruby/httpclient/Manifest
index 2d0e13c91747..938b3b7361c0 100644
--- a/dev-ruby/httpclient/Manifest
+++ b/dev-ruby/httpclient/Manifest
@@ -1,4 +1,3 @@
DIST httpclient-2.8.3.tgz 464624 BLAKE2B ce8ed523a24acce219027a4f1985caf2b4dae29bdba038ca2397e5f4d4b36c90b35cedfb62faa7faf426c3ce8589906df7832968c81b64bc9100eff6f4fe9745 SHA512 b65b5adb97af069d7ff6b6f4cccd6a42c6d9c88b797e9495768fe1f36a6bd93defe50190edc201de5e39c4e306ba0bd17a8ff2f8eba4d636dacafa06c172967d
-EBUILD httpclient-2.8.3-r1.ebuild 2739 BLAKE2B 2e53c14e13ef50880da49fcd5f254657b643f0bd81dd93d7ffdbd0a7baf78166ca5d4ba739d471951be5b1e7e0d8057e7d9c42af9bd505dc6e5c6ac2576e94cc SHA512 8c10f9197b9e313d7bf69026de5d2e724e0a23b2803dc6e47adc6a2e766ec9faf1064384ab7a5781b82500e758aeb9058c332df5d1bb936f3f6fe6d0fa589acb
-EBUILD httpclient-2.8.3.ebuild 1969 BLAKE2B a10ed12b97cc24a02346b21fe2bfadaecc49085455193434d9885aec83de029e1a00aab57332ceb32061bbe483842fba7af1b62f6e39ee8286743774e5b32cc8 SHA512 7c41c093baf46568dffaa43f44cd8d2dc0e264fea00bd04b885586711ef6756a0647f93076f5e068b593fbbebd0559729be7f088d60f53bec1e88426dc49e4d4
+EBUILD httpclient-2.8.3-r2.ebuild 2722 BLAKE2B 2efa1a0f50106a3ee376b2a7a5920293577b3a4c717108e22e54c6c596c0f66a9e45d0b08537934dc5f79956c174598095b3e697435fd8076cee33215462d394 SHA512 c8c6e10ecf5ef6cb5ec8fa3e6de0d92f5355d5fd37a519bd5bbe2afeb1f2b4317f56562c71a8ff32d3a0d10ae668509f29dd51eaf8d00c3b1b83460676babe23
MISC metadata.xml 342 BLAKE2B 357371edae972dc4bf17bef8a0ddf752bd81a3936a4ba6cc83ec7a253346e3d236bb0930fc71f14c1c42a486f3202bcd08352260aef38676f57b31f852dcca27 SHA512 3c3e6861463a129c5679658a044b956f1d8a4ad086c5fc77029037ad88b391af06cfbe26127127ae0b909d602c9a3b02929c48d7a26059ebd29e06c394d7b4c4
diff --git a/dev-ruby/httpclient/httpclient-2.8.3-r1.ebuild b/dev-ruby/httpclient/httpclient-2.8.3-r2.ebuild
index c9e2e593e099..02735b703690 100644
--- a/dev-ruby/httpclient/httpclient-2.8.3-r1.ebuild
+++ b/dev-ruby/httpclient/httpclient-2.8.3-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
USE_RUBY="ruby26 ruby27 ruby30"
@@ -14,7 +14,7 @@ RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
RUBY_FAKEGEM_GEMSPEC="httpclient.gemspec"
-inherit ruby-fakegem eapi8-dosym
+inherit ruby-fakegem
DESCRIPTION="'httpclient' gives something like the functionality of libwww-perl (LWP) in Ruby"
HOMEPAGE="https://github.com/nahi/httpclient"
@@ -23,7 +23,7 @@ SRC_URI="https://github.com/nahi/httpclient/archive/v${PV}.tar.gz -> ${P}.tgz"
LICENSE="Ruby"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
IUSE=""
ruby_add_rdepend "virtual/ruby-ssl"
@@ -74,5 +74,5 @@ each_ruby_install() {
# fix this copy for production systems
# do not ship the cacert1024.pem at all anymore, nobody should use RSA1024 certs!
rm -f "${ED}/$(ruby_fakegem_gemsdir)/gems/${RUBY_FAKEGEM_NAME}-${RUBY_FAKEGEM_VERSION}/lib/httpclient/"{cacert.pem,cacert1024}.pem
- dosym8 -r /etc/ssl/certs/ca-certificates.crt $(ruby_fakegem_gemsdir)/gems/${RUBY_FAKEGEM_NAME}-${RUBY_FAKEGEM_VERSION}/lib/httpclient/cacert.pem
+ dosym -r /etc/ssl/certs/ca-certificates.crt $(ruby_fakegem_gemsdir)/gems/${RUBY_FAKEGEM_NAME}-${RUBY_FAKEGEM_VERSION}/lib/httpclient/cacert.pem
}
diff --git a/dev-ruby/httpclient/httpclient-2.8.3.ebuild b/dev-ruby/httpclient/httpclient-2.8.3.ebuild
deleted file mode 100644
index 160c1d9af9dd..000000000000
--- a/dev-ruby/httpclient/httpclient-2.8.3.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_TASK_TEST="-Ilib test"
-RUBY_FAKEGEM_TASK_DOC="doc"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="httpclient.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="'httpclient' gives something like the functionality of libwww-perl (LWP) in Ruby"
-HOMEPAGE="https://github.com/nahi/httpclient"
-SRC_URI="https://github.com/nahi/httpclient/archive/v${PV}.tar.gz -> ${P}.tgz"
-
-LICENSE="Ruby"
-SLOT="0"
-
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend "virtual/ruby-ssl"
-
-ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
-ruby_add_bdepend "test? ( dev-ruby/test-unit dev-ruby/http-cookie )"
-
-all_ruby_prepare() {
- rm Gemfile || die
- sed -i -e '/[bB]undler/s:^:#:' Rakefile || die
-
- # Fix documentation task
- sed -i -e 's/README.txt/README.md/' Rakefile || die
-
- # Remove mandatory CI reports since we don't need this for testing.
- sed -i -e '/reporter/s:^:#:' Rakefile || die
-
- # Remove mandatory simplecov dependency
- sed -i -e '/[Ss]imple[Cc]ov/ s:^:#:' test/helper.rb || die
-
- # Comment out test requiring network access that makes assumptions
- # about the environment, bug 395155
- sed -i -e '/test_async_error/,/^ end/ s:^:#:' test/test_httpclient.rb || die
-
- # Skip tests using rack-ntlm which is not packaged. Weirdly these
- # only fail on jruby.
- rm test/test_auth.rb || die
-
- # Skip test failing due to hard-coded expired certificate
- sed -i -e '/test_verification_without_httpclient/,/^ end/ s:^:#:' test/test_ssl.rb || die
-
- # Skip test depending on obsolete and vulnerable SSLv3
- sed -i -e '/test_no_sslv3/,/^ end/ s:^:#:' test/test_ssl.rb || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:test:. -e 'gem "test-unit"; Dir["test/test_*.rb"].each{|f| require f}' || die
-}