summaryrefslogtreecommitdiff
path: root/dev-ruby/httparty
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/httparty
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/httparty')
-rw-r--r--dev-ruby/httparty/Manifest5
-rw-r--r--dev-ruby/httparty/httparty-0.16.0.ebuild49
-rw-r--r--dev-ruby/httparty/httparty-0.16.2.ebuild52
-rw-r--r--dev-ruby/httparty/metadata.xml8
4 files changed, 114 insertions, 0 deletions
diff --git a/dev-ruby/httparty/Manifest b/dev-ruby/httparty/Manifest
new file mode 100644
index 000000000000..52aa4140397c
--- /dev/null
+++ b/dev-ruby/httparty/Manifest
@@ -0,0 +1,5 @@
+DIST httparty-0.16.0.gem 89088 BLAKE2B 27715c6760a9adeec289a005f89de219b32e6ad5c3f937478ad4187df895096f9375b0d20a4b33c1c62b96de6313017a713a036247756a96fe9366e7c1e77247 SHA512 c523ab3555d0a86e2df53e800be57b88f40bb680e7df31e754ddc3e76728eb2228e6ddbe9a3e580c4c604a126ebcd33be79dfde3758faf99aadbba4d30d9508d
+DIST httparty-0.16.2.gem 89600 BLAKE2B 581b5fcadf59bb50864b2fa6d1aae220ff9881bba53363601c6e70c3291dc2cee351a8f42b1946ad516cdcab5a85b832e4260f04394e54255e0cd76bc6860d5e SHA512 13efbacb9ee0325fbb185279ca9f7ffcc0131189ccf98d9889c6a1b6bcfa04fd7cbc6d1393bffe69a5a813a2f54f70b5926e176305fa70480dd0902968c894d0
+EBUILD httparty-0.16.0.ebuild 1246 BLAKE2B d3305c8cd1703486ab374b67d5a8a197e6c9ce0b700e570ba1407148aa692ab1c402f5977e263aa4303a6b3e6bf356297f7572d3a582ae306c9937909c65d137 SHA512 ff0d3fce64021e7ae05c74bd58576bdafd00c52d0ac9241e2faa899f8f12baccbb141f23778f35d0a2878bb468bd8c4cd440fb78d963851053136e6584c0d806
+EBUILD httparty-0.16.2.ebuild 1426 BLAKE2B f58dcc637bab3233e777320e7b94e354c5878bb5982d504cafc37ebbf425eb34802dbacc4671c44223028bebed42b74bc74bc79b9d5894a00fe930e88e0c06ae SHA512 00266485131548e262e827c68edc47eaf2195d1d70ea5c6b11a59a64952cf352b1413a4856440eccc40ca256aa467ef759ca41daa963ca6e8e1154fba1a3ec38
+MISC metadata.xml 247 BLAKE2B 7717702c51c35b2a20983332abc6218047b2b5036e6b4c09d3d58b4339e8f9e776879cd116cfda60d3bcf4188859993fb9f3f779aaf595f155d53e85288f3dcc SHA512 ea4c044637b751a2c28c6ac226121e74ef18196af4b594e60413fec907bbab29c6b0c7735c3f503485df16dcfb36ddb86038394d92e2cd18c8f04626628e9f09
diff --git a/dev-ruby/httparty/httparty-0.16.0.ebuild b/dev-ruby/httparty/httparty-0.16.0.ebuild
new file mode 100644
index 000000000000..472d30ad10ff
--- /dev/null
+++ b/dev-ruby/httparty/httparty-0.16.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Makes http fun! Also, makes consuming restful web services dead easy"
+HOMEPAGE="https://jnunemaker.github.com/httparty"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend '>=dev-ruby/multi_xml-0.5.2'
+
+ruby_add_bdepend 'test? ( dev-ruby/webmock )'
+
+all_ruby_prepare() {
+ # Remove bundler
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+
+ # Avoid test dependency on cucumber. We can't run the features since
+ # they depend on mongrel which is no longer packaged.
+ sed -i -e '/cucumber/I s:^:#:' Rakefile || die
+
+ # Avoid test dependency on simplecov
+ sed -i -e '/simplecov/I s:^:#:' \
+ -e '1i require "cgi"; require "delegate"' spec/spec_helper.rb || die
+
+ # Avoid test that works standalone but fails in the suite
+ sed -i -e '/calls block given to perform with each redirect/,/^ end/ s:^:#:' spec/httparty/request_spec.rb
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+}
diff --git a/dev-ruby/httparty/httparty-0.16.2.ebuild b/dev-ruby/httparty/httparty-0.16.2.ebuild
new file mode 100644
index 000000000000..b173eb0fcdbf
--- /dev/null
+++ b/dev-ruby/httparty/httparty-0.16.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Makes http fun! Also, makes consuming restful web services dead easy"
+HOMEPAGE="https://jnunemaker.github.com/httparty"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend '>=dev-ruby/multi_xml-0.5.2'
+
+ruby_add_bdepend 'test? ( dev-ruby/webmock )'
+
+all_ruby_prepare() {
+ # Remove bundler
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+
+ # Avoid test dependency on cucumber. We can't run the features since
+ # they depend on mongrel which is no longer packaged.
+ sed -i -e '/cucumber/I s:^:#:' Rakefile || die
+
+ # Avoid test dependency on simplecov
+ sed -i -e '/simplecov/I s:^:#:' \
+ -e '1i require "cgi"; require "delegate"' spec/spec_helper.rb || die
+
+ # Avoid test that works standalone but fails in the suite
+ sed -i -e '/calls block given to perform with each redirect/,/^ end/ s:^:#:' spec/httparty/request_spec.rb
+
+ # Avoid test that is not fully compatible with newer multi_xml
+ sed -i -e '/should be able parse response type xml automatically/askip "multi_xml"' spec/httparty_spec.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+}
diff --git a/dev-ruby/httparty/metadata.xml b/dev-ruby/httparty/metadata.xml
new file mode 100644
index 000000000000..28ab0c15f206
--- /dev/null
+++ b/dev-ruby/httparty/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+</maintainer>
+</pkgmetadata>