summaryrefslogtreecommitdiff
path: root/dev-ruby/httparty
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-02 08:23:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-02 08:23:39 +0000
commit6b3ca90478d729cccd6c9ce421860aa84c9de282 (patch)
treed03414daeb9f9d87aad9c1b22bcda26c8fadedac /dev-ruby/httparty
parent9d7dcb261c1433eafda094d4f0524d4a2a781b8d (diff)
gentoo auto-resync : 02:01:2023 - 08:23:39
Diffstat (limited to 'dev-ruby/httparty')
-rw-r--r--dev-ruby/httparty/Manifest2
-rw-r--r--dev-ruby/httparty/httparty-0.21.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-ruby/httparty/Manifest b/dev-ruby/httparty/Manifest
index 218549576608..23f7dd3c9a18 100644
--- a/dev-ruby/httparty/Manifest
+++ b/dev-ruby/httparty/Manifest
@@ -1,3 +1,5 @@
DIST httparty-0.20.0.tar.gz 101975 BLAKE2B f15eb837a4bbc98de501e6dcca5a17bb0906e8ea6671c55a85d665659ab60bcee5e84d9dafad6b2450e22cedfaf5a86e10e077e52b1120ff9ae2613a1176a651 SHA512 f5770d5a64be2e80aa70334dad899fb723b08088a673a788ca1402285b77ae6b3cef21e3ed263d9618a32879711c9183f2dc82ff7b50bcf6439a8e6bb7a2eb4e
+DIST httparty-0.21.0.tar.gz 102735 BLAKE2B 131c4f3a5a403b609391ececaf079de5ed5c57ea4660fc1d1041832d8baa27b8beaf11ac2743aa6059005904d787259afec27597744bb5e35e56c3b035ca4b1b SHA512 afd50de88a6b1e1cac8c90d6e1458c41ef122b4542c3a14274aacb052f9ceafad868d1b2582d45eedd212a8037fac13238ac05c2e661c9ba9196a00ef3a0a634
EBUILD httparty-0.20.0.ebuild 1850 BLAKE2B 371affee23c802eaaf97a101ca6cc90aef26eba1d2f3ea647af86eba15e6424ab8709d39e54b22b771577292f4c93fb6da86d3ae41b0823f3e55d172f7a48c74 SHA512 d17e3945617b59fefce6b3faa7a1c45edf5783da4af097769f16d3a11a1bbe725166f7d4709b3803f34f41dfbeb0d91180c68b1296f7c972c9f13d2691aae382
+EBUILD httparty-0.21.0.ebuild 1849 BLAKE2B dd7f1e59afe5fbbf9247ea0c1157f32ad9798f2a9b8d30fa8fe67425c9b5c284f906ea474e0bf4d5f25844fbb3ce79a917f6877e72e6b262530fe314a9da1e62 SHA512 fbaad90cadf9f81616c1c47d8a1377bb71446c6fcd64f11700663bf42db74f4544766bf06c5485940356754112ee3019a73ef8340574280bc2d832341023c2ba
MISC metadata.xml 248 BLAKE2B 0c876bde3c72e61d28284a95a837103e6d594c9f6fccbd6d7d1039f9c5a604347c20c334c9a57d80b152888fed536196f2807b477e8d0336c80affb0e28c9dc9 SHA512 b2b64178cf6cbbaa5fb4671ffe1ab88b83c920de363ae099ef74fa3e5eb8c8f0285c749cabc0cebf344951503d1b7309ae294afe9e7cf5172700182d8843fa14
diff --git a/dev-ruby/httparty/httparty-0.21.0.ebuild b/dev-ruby/httparty/httparty-0.21.0.ebuild
new file mode 100644
index 000000000000..bc2ccb2f5ffe
--- /dev/null
+++ b/dev-ruby/httparty/httparty-0.21.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="httparty.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Makes http fun! Also, makes consuming restful web services dead easy"
+HOMEPAGE="https://jnunemaker.github.com/httparty"
+SRC_URI="https://github.com/jnunemaker/httparty/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend '>=dev-ruby/mini_mime-1.0.0 >=dev-ruby/multi_xml-0.5.2'
+
+ruby_add_bdepend 'test? ( dev-ruby/webmock )'
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files \?-\?-\?/find/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Remove bundler
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+
+ # Avoid test dependency on cucumber. We can't run the features since
+ # they depend on mongrel which is no longer packaged.
+ sed -i -e '/cucumber/I s:^:#:' Rakefile || die
+
+ # Avoid test dependency on simplecov
+ sed -i -e '/simplecov/I s:^:#:' \
+ -e '/pry/ s:^:#:' \
+ -e '1i require "cgi"; require "delegate"' spec/spec_helper.rb || die
+
+ # Avoid test that works standalone but fails in the suite
+ #sed -i -e '/calls block given to perform with each redirect/,/^ end/ s:^:#:' spec/httparty/request_spec.rb
+
+ # Avoid test that is not fully compatible with newer multi_xml
+ sed -i -e '/should be able parse response type xml automatically/askip "multi_xml"' spec/httparty_spec.rb || die
+
+ # Avoid test that fails due to unicode normalization differences
+ sed -i -e '/handles international domains/askip "unicode differences"' spec/httparty_spec.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+}