summaryrefslogtreecommitdiff
path: root/dev-ruby/http_parser_rb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-28 15:04:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-28 15:04:41 +0100
commite74494cd71c90a42f7cf78ec655c9c883a26c42a (patch)
tree06c91f279ebdf8ba4dcdab90385d7fb04a4d0e27 /dev-ruby/http_parser_rb
parent35e8572a0d6310d3eac4be1600ef2de6cb6881ab (diff)
gentoo auto-resync : 28:07:2022 - 15:04:40
Diffstat (limited to 'dev-ruby/http_parser_rb')
-rw-r--r--dev-ruby/http_parser_rb/Manifest2
-rw-r--r--dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r2.ebuild11
2 files changed, 9 insertions, 4 deletions
diff --git a/dev-ruby/http_parser_rb/Manifest b/dev-ruby/http_parser_rb/Manifest
index 24cb5b5e5439..c470c7155a2f 100644
--- a/dev-ruby/http_parser_rb/Manifest
+++ b/dev-ruby/http_parser_rb/Manifest
@@ -1,3 +1,3 @@
DIST http_parser.rb-0.6.0.gem 177664 BLAKE2B ecae9e862454584759cbb3158eb16dd6de09fe95c6b38099f1c6d4be2376ca1d3eb8a6713994da600c9c567193466da30f4784652e19ad796891a53d67578fff SHA512 51c29bfc85de8cedb4e98fec84c955252556abaa4d0848fbc38b232879ffc946c72acf38440e8e9f1e31a8b734a68d43a96924af5f48ac4f1a054153ec913a08
-EBUILD http_parser_rb-0.6.0-r2.ebuild 560 BLAKE2B 75d874ae271a3898a1b8833fd7b6f7878f080401b6bbd7542c9f4dc9fb7d0fc1d74a2633f27580578e4dbbe490f83c887a1f236a0655b2fd20ae73ee2f7e4eb3 SHA512 5b1aa831dfc2adddfc8a81108a147368e2d19a1ef69b8cea0349a31408f53268f0109b98feb6e9a509665692c371869b231156e97ec4fa84cb7ca73fb622f6df
+EBUILD http_parser_rb-0.6.0-r2.ebuild 705 BLAKE2B 2bedd1e7cac4fa9129bcb49457f0cf6ea294b1fbd017482aa483cd2a3541d2220e7caeb4e207d039a32c5f774b96ee130734172a22b0884892df126f68e9c8b4 SHA512 4096a3997be08dfb0987aeef363e9a5a5b8ad8d77fe254693b953c6c97b7bd63b840a4b4735584ea50d0022822e2e5c65bd66b5e34346390bee539e3c15747ca
MISC metadata.xml 346 BLAKE2B 5169aa2eacb36006a706985194bb349b880218b8c3afc90562bb91cab866af9561b1e72059521f620655eb1e7043d9fcc1184803b14a6283b28c31f17ab39f4d SHA512 0ef4e4755e5bfe794e212752ebd76b1251597edce300f8fc3ff731cb8774418ed2fafb6ba3444a7ea266910d9bd4ed04ef08b07a3d97eaf7b120f01f3c01e129
diff --git a/dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r2.ebuild b/dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r2.ebuild
index 26c7f9681990..c8083353aa1e 100644
--- a/dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r2.ebuild
+++ b/dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby26 ruby27"
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="README.md"
@@ -22,3 +22,8 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc x86"
IUSE=""
+
+all_ruby_prepare() {
+ # rspec 3 compatibility
+ sed -i -e 's/be_true/be true/; s/be_false/be false/' spec/parser_spec.rb || die
+}