summaryrefslogtreecommitdiff
path: root/dev-ruby/http_parser_rb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/http_parser_rb
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/http_parser_rb')
-rw-r--r--dev-ruby/http_parser_rb/Manifest3
-rw-r--r--dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r1.ebuild31
-rw-r--r--dev-ruby/http_parser_rb/metadata.xml11
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/http_parser_rb/Manifest b/dev-ruby/http_parser_rb/Manifest
new file mode 100644
index 000000000000..05f5b8e351bf
--- /dev/null
+++ b/dev-ruby/http_parser_rb/Manifest
@@ -0,0 +1,3 @@
+DIST http_parser.rb-0.6.0.gem 177664 BLAKE2B ecae9e862454584759cbb3158eb16dd6de09fe95c6b38099f1c6d4be2376ca1d3eb8a6713994da600c9c567193466da30f4784652e19ad796891a53d67578fff SHA512 51c29bfc85de8cedb4e98fec84c955252556abaa4d0848fbc38b232879ffc946c72acf38440e8e9f1e31a8b734a68d43a96924af5f48ac4f1a054153ec913a08
+EBUILD http_parser_rb-0.6.0-r1.ebuild 704 BLAKE2B d0580d8e1b8d2fbb232b64e8301f6bd748662c0ccf88bdf0cc14b8763f1c20f2421a84dc96951a29388e63521a3800a23910923f988c16e592f3b389db7f2ccb SHA512 4d476d0f40e914b79b9f9c1eaf7beb0fd2b203c7497a733f5fae2ad32bc5e78b9a32e5acba64790a3075660e0657b0cd13863054d9e2d1b6adb420e984ae547b
+MISC metadata.xml 345 BLAKE2B 8305f5931644b1a23580704e713a643f9ffaf40285edba69bdcea258bedbbbacf3486fa4703e4989b7d727b874da12726b970d46781ed72093a349911468de68 SHA512 86cb5c3b5137de6cd0792a3bcda1b028e3dfbe349d7ee7bb4df47b47a796469213681bb686dcc0fd3132b44b78366c11757d922d633607915dadd40faa6c3453
diff --git a/dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r1.ebuild b/dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..0c7960f923d8
--- /dev/null
+++ b/dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_NAME="http_parser.rb"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple callback-based HTTP request/response parser"
+HOMEPAGE="https://github.com/tmm1/http_parser.rb"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 x86"
+IUSE=""
+
+each_ruby_configure() {
+ ${RUBY} -Cext/ruby_http_parser extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/ruby_http_parser V=1
+ cp ext/ruby_http_parser/ruby_http_parser.so lib/ || die
+}
diff --git a/dev-ruby/http_parser_rb/metadata.xml b/dev-ruby/http_parser_rb/metadata.xml
new file mode 100644
index 000000000000..549c8510b11b
--- /dev/null
+++ b/dev-ruby/http_parser_rb/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tmm1/http_parser.rb</remote-id>
+ </upstream>
+</pkgmetadata>