summaryrefslogtreecommitdiff
path: root/dev-ruby/http-parser
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-ruby/http-parser
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-ruby/http-parser')
-rw-r--r--dev-ruby/http-parser/Manifest4
-rw-r--r--dev-ruby/http-parser/http-parser-1.2.2.ebuild6
-rw-r--r--dev-ruby/http-parser/http-parser-1.2.3.ebuild29
3 files changed, 35 insertions, 4 deletions
diff --git a/dev-ruby/http-parser/Manifest b/dev-ruby/http-parser/Manifest
index ddd44223b289..1087776dbe0b 100644
--- a/dev-ruby/http-parser/Manifest
+++ b/dev-ruby/http-parser/Manifest
@@ -1,3 +1,5 @@
DIST http-parser-1.2.2.gem 32256 BLAKE2B bc1600497db7c0ae9ee9311a6eae6494090b190b49d37809671d0c2fbb3b56ab4709dd16b68c7bfe8fc75609fc6f01d31c21c92681b9adbb4c83e521991d9172 SHA512 cffc1561657b7cb50c446e54da20176870ffe5f1acfe5e9fadfeacbea421fcc89243dd8f4a04d7933e19c155662fcd47db950c3743968d7981c52aa6c0a43ab5
-EBUILD http-parser-1.2.2.ebuild 648 BLAKE2B 342fd0c57f727bef330c3057e0c93b7f36523263ada698d8f44a3ad0fd430819752e2a3dd54bb45a25d13411cebfa4454e04334de6d1d7c3d4447a9d1c2b12be SHA512 c62b17b6c4d3b34567ec8cac2369f410fbb1214c2a7896114c35acdfdf96687d8cfbda7d4f48a3d3b90c73bbf812f66dfc7b8dc0067d1e7d81e84f2587ec2d88
+DIST http-parser-1.2.3.gem 31232 BLAKE2B 055ab9ccb42bb85f87b65eeaa59f645ec390f0751eb379b22b1a2c83920ef1c482a3bed8f5105843c341fe92ba0c8d44272688b929bca13c690945f7e37b282f SHA512 03c34c3e8174d9010440483af34800b74a7bbddd5daa63607e6aa2254d9c91cf36d90854ea65827b32680432de278aeeb7b8878f788f124c150f163409fa5107
+EBUILD http-parser-1.2.2.ebuild 630 BLAKE2B ac881c10e770eb83bf1527965763c052ff56f3eaad578f82d4247a562416a4f3fdbb0e12ee441a2824d6ceba720013b9df6c14d16879cce304d90b387f15d4a0 SHA512 ce4bceeb4f80b58ce5a311453b1559929eafb1a1349f21aac869260a4d8ee8695737251a0d46310833da6719943ef1dbcfc2840bdfc0119562a99b3b411a1a5c
+EBUILD http-parser-1.2.3.ebuild 642 BLAKE2B 122b4676d3b40aef477aab983b0175087859c942123d4ede2c2de9571aba2ecfa8a4977385951c4b3e86ead4c2d0a0bee9e3867463cf730de1b04494164effb0 SHA512 c72e67c6c372a7b614a74ef6b4ba6fa482bf977283bb1ab5f37f06c1bde914a5e2ffde1040bbdc2a091c2975a9f09dfda847d4a19df023a032052f5202b196be
MISC metadata.xml 343 BLAKE2B 72290387c9fcabd2fc09db5cd44f3676f1b8bd033aeabce6bc0b1a52eb9af14b7908b48c9c5a765af0af4578b3d3c54574f5793acc1869d97ba70b8d82545bda SHA512 efc0c6cc3d88913690573b792e3ee051538034bb5d6b368cefa4d558e91ef6104060007a8d605299ee18bd67727a122752eaf754ecb341d596e1b3bc5e1b1ace
diff --git a/dev-ruby/http-parser/http-parser-1.2.2.ebuild b/dev-ruby/http-parser/http-parser-1.2.2.ebuild
index 796554e18319..e3227ecbebf8 100644
--- a/dev-ruby/http-parser/http-parser-1.2.2.ebuild
+++ b/dev-ruby/http-parser/http-parser-1.2.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+USE_RUBY="ruby25 ruby26 ruby27"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
@@ -25,5 +25,5 @@ ruby_add_bdepend "dev-ruby/ffi-compiler"
each_ruby_compile() {
${RUBY} -C ext -S rake || die
- mv ext/x86_64-linux/libhttp-parser-ext.so lib/http-parser/ || die
+ mv ext/*/libhttp-parser-ext.so lib/http-parser/ || die
}
diff --git a/dev-ruby/http-parser/http-parser-1.2.3.ebuild b/dev-ruby/http-parser/http-parser-1.2.3.ebuild
new file mode 100644
index 000000000000..61c84cda710b
--- /dev/null
+++ b/dev-ruby/http-parser/http-parser-1.2.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A super fast http parser for ruby"
+HOMEPAGE="https://github.com/cotag/http-parser"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE=""
+
+DEPEND+=" >=net-libs/http-parser-2.8.1"
+RDEPEND+=" >=net-libs/http-parser-2.8.1"
+
+ruby_add_bdepend "dev-ruby/ffi-compiler"
+
+each_ruby_compile() {
+ ${RUBY} -C ext -S rake || die
+ mv ext/*/libhttp-parser-ext.so lib/http-parser/ || die
+}