summaryrefslogtreecommitdiff
path: root/dev-ruby/http-parser
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
commit441d1370330332b7d78f238d2f5e13f7aed5e4e0 (patch)
tree6a5171dd615dfeee62a45044144c66e864738fb0 /dev-ruby/http-parser
parentab3da91fb6c91a9df52fff8f991570f456fd3c7a (diff)
gentoo christmass resync : 25.12.2020
Diffstat (limited to 'dev-ruby/http-parser')
-rw-r--r--dev-ruby/http-parser/Manifest3
-rw-r--r--dev-ruby/http-parser/http-parser-1.2.2.ebuild29
-rw-r--r--dev-ruby/http-parser/metadata.xml11
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/http-parser/Manifest b/dev-ruby/http-parser/Manifest
new file mode 100644
index 000000000000..ddd44223b289
--- /dev/null
+++ b/dev-ruby/http-parser/Manifest
@@ -0,0 +1,3 @@
+DIST http-parser-1.2.2.gem 32256 BLAKE2B bc1600497db7c0ae9ee9311a6eae6494090b190b49d37809671d0c2fbb3b56ab4709dd16b68c7bfe8fc75609fc6f01d31c21c92681b9adbb4c83e521991d9172 SHA512 cffc1561657b7cb50c446e54da20176870ffe5f1acfe5e9fadfeacbea421fcc89243dd8f4a04d7933e19c155662fcd47db950c3743968d7981c52aa6c0a43ab5
+EBUILD http-parser-1.2.2.ebuild 648 BLAKE2B 342fd0c57f727bef330c3057e0c93b7f36523263ada698d8f44a3ad0fd430819752e2a3dd54bb45a25d13411cebfa4454e04334de6d1d7c3d4447a9d1c2b12be SHA512 c62b17b6c4d3b34567ec8cac2369f410fbb1214c2a7896114c35acdfdf96687d8cfbda7d4f48a3d3b90c73bbf812f66dfc7b8dc0067d1e7d81e84f2587ec2d88
+MISC metadata.xml 343 BLAKE2B 72290387c9fcabd2fc09db5cd44f3676f1b8bd033aeabce6bc0b1a52eb9af14b7908b48c9c5a765af0af4578b3d3c54574f5793acc1869d97ba70b8d82545bda SHA512 efc0c6cc3d88913690573b792e3ee051538034bb5d6b368cefa4d558e91ef6104060007a8d605299ee18bd67727a122752eaf754ecb341d596e1b3bc5e1b1ace
diff --git a/dev-ruby/http-parser/http-parser-1.2.2.ebuild b/dev-ruby/http-parser/http-parser-1.2.2.ebuild
new file mode 100644
index 000000000000..796554e18319
--- /dev/null
+++ b/dev-ruby/http-parser/http-parser-1.2.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A super fast http parser for ruby"
+HOMEPAGE="https://github.com/cotag/http-parser"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND+=" >=net-libs/http-parser-2.8.1"
+RDEPEND+=" >=net-libs/http-parser-2.8.1"
+
+ruby_add_bdepend "dev-ruby/ffi-compiler"
+
+each_ruby_compile() {
+ ${RUBY} -C ext -S rake || die
+ mv ext/x86_64-linux/libhttp-parser-ext.so lib/http-parser/ || die
+}
diff --git a/dev-ruby/http-parser/metadata.xml b/dev-ruby/http-parser/metadata.xml
new file mode 100644
index 000000000000..6934c42f882b
--- /dev/null
+++ b/dev-ruby/http-parser/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">cotag/http-parser</remote-id>
+ </upstream>
+</pkgmetadata>