summaryrefslogtreecommitdiff
path: root/dev-ruby/http-cookie
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-ruby/http-cookie
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-ruby/http-cookie')
-rw-r--r--dev-ruby/http-cookie/Manifest2
-rw-r--r--dev-ruby/http-cookie/http-cookie-1.0.4.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/http-cookie/Manifest b/dev-ruby/http-cookie/Manifest
index fbb950f948f2..2c4cc29b6d36 100644
--- a/dev-ruby/http-cookie/Manifest
+++ b/dev-ruby/http-cookie/Manifest
@@ -1,3 +1,5 @@
DIST http-cookie-1.0.3.gem 38400 BLAKE2B 6b7292b2a5d7c37b6769cdd38f01d8cf78aa9557b4a204d736dffeae5d31768c57ac58f00577df78252f9a8bdb12a7faecf5e1be64c8ee29aaf67cc9307d0a35 SHA512 43ac1218e98dd47ee22e33e72e20bc5b55f65e60aadd417641f8a4221eba88995d418c7738a4c35dfba132e05c0c4b0df2b2bedd56c22e82c062d1f03de0052f
+DIST http-cookie-1.0.4.gem 39424 BLAKE2B 06ac0e667340ac17827a8eb4ed320efe77ad97509fcd444f7e77d887a77643a6b34e84486db78eba52245891d1719e750d9a446c40a4ab7804f2304b600029bd SHA512 788fdaa642e6b596e7a91c57a7942a832c09a84fed88b30fdd8e5a8ad66d72780afc1246e6c83c4dfd5af8018c278750866dd05d804aef793aa067b09519af8d
EBUILD http-cookie-1.0.3.ebuild 692 BLAKE2B 3ec06e785b3a87a4d0a46abddfa876bd48ca3bdbd496396beaf17b0633d3d1488e990e57ea923dad6dd60717bc510d38d48e8cbc38d733da9b7dc054fc4b6983 SHA512 54a88bf86a64dd16444442d97872692cc25964fcc4febdab2a2efe4fdc86b2b9ff49ad6a5779087d274a3bf90b7a3af1e76d9a1a6a7368c9d3b6b79421f3c05e
+EBUILD http-cookie-1.0.4.ebuild 666 BLAKE2B 39191bfc028a76f23bdd08944aa06d7a51763ec11ef3c2c2a01f06d7dac6c49c6b4606c6d544e2315018c1554f2dded2916f6f6b80a3435a533fe8bd9df99d96 SHA512 2a08cae456f13fe26e7923ae491421bec6d24cd4c500dec6c4e8bcb3d831820e438058f8682e6c397b91749cde477774dfc8500eaf9a0f6bf50a9b405e352dd3
MISC metadata.xml 351 BLAKE2B 926eb407cb14931a24791340dd7b529823fcf35a7ed86f5b9f13a6238db82d71f71775f4820b07056d486c299afb97b23acb0f6419fbbeab69feb4b49e667950 SHA512 e9ad64c767ea22fcd169c61f71dfd8b292592e6efcb27273df9d90584e39897434d52f974037694f346d8388564fa8b8550f2da1ac11ef4e4a2e450e11701efc
diff --git a/dev-ruby/http-cookie/http-cookie-1.0.4.ebuild b/dev-ruby/http-cookie/http-cookie-1.0.4.ebuild
new file mode 100644
index 000000000000..d4c813797e61
--- /dev/null
+++ b/dev-ruby/http-cookie/http-cookie-1.0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby library to handle HTTP cookies"
+HOMEPAGE="https://github.com/sparklemotion/http-cookie"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/domain_name-0.5:0"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/d" -e "/bundler/d" Rakefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_http_cookie.rb || die
+ ${RUBY} -Ilib test/test_http_cookie_jar.rb || die
+}