summaryrefslogtreecommitdiff
path: root/dev-ruby/http-cookie
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-13 05:42:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-13 05:42:42 +0100
commit37cf2a8dbadd546a550aac7c8079c3f77427cb63 (patch)
tree01b4d88cf5ffbb0cc059bd4e1cbca9d8352ee900 /dev-ruby/http-cookie
parent7bb99171a372e6cff495daf7dbef2e03d216be29 (diff)
gentoo auto-resync : 13:04:2023 - 05:42:42
Diffstat (limited to 'dev-ruby/http-cookie')
-rw-r--r--dev-ruby/http-cookie/Manifest1
-rw-r--r--dev-ruby/http-cookie/http-cookie-1.0.5-r1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/http-cookie/Manifest b/dev-ruby/http-cookie/Manifest
index a0c4e664b83d..0a58e48403f8 100644
--- a/dev-ruby/http-cookie/Manifest
+++ b/dev-ruby/http-cookie/Manifest
@@ -1,3 +1,4 @@
DIST http-cookie-1.0.5.gem 39424 BLAKE2B 569a0d18c962be378f3974b400ddf2289c72490b2b93619fcd83ed6c00bbf5def76239c52163dc6231060792abf3a19988285a6cd28f158ff7339252da912e61 SHA512 d530d64b5c2fc3757a6de03384fe768317e24a523d4a4215f5bcc6b5bca9e7b94eeaad1e52fbb67548396b7b2ca7c9d8b68ea7b99109e24770fcf34c950469ef
+EBUILD http-cookie-1.0.5-r1.ebuild 780 BLAKE2B 07eb850cb68e240e14e9098bc5c8657e62e193fd627f7de05c0965d7d3858e349190c34177d7ba5c934e1eb03226df3443ea0cfb2cb00ad7f49e519f368404b2 SHA512 c81fffa880a6c3e086ea92ef85031436da002cb80c9e36d7e9bbf8a2b6002185dfb15638cb33620371a4af18b80170dbee383ceb161315a37ee3db61949f5761
EBUILD http-cookie-1.0.5.ebuild 772 BLAKE2B eec39d07e71a27e263e427472ee4f721af3a62d97bbe63aa5d6031c6e52e548b7f33ac2fbef978257db3a290e95b1d96590bdc21c746e77db070b5d32c4205d4 SHA512 f2bdfc6f52a9e37fa401c1b3ceea05c668586b431f3c48a6cc2f8302b289b83045505702716881d0add107845c78d34088514f15dcd2c10b8e0cd3af4adaceb6
MISC metadata.xml 352 BLAKE2B 0e1cc1e4cc97d4d773c64a068d2f7246c863fae1c17504f83275d1ab15e59a9bc6535c22fdf0c02d89d778079d100b74e29170b0fbe6fc1ad5464e221751a56d SHA512 821e08b75914f51a4a341149db588c8e3b17fc401a14de9abd44918b9f6bf88bc1d9c76b460a10c1b312669db478759aab90d0bb08bc04129bc8c964e7b3a314
diff --git a/dev-ruby/http-cookie/http-cookie-1.0.5-r1.ebuild b/dev-ruby/http-cookie/http-cookie-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..6e8ed8373fb5
--- /dev/null
+++ b/dev-ruby/http-cookie/http-cookie-1.0.5-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby library to handle HTTP cookies"
+HOMEPAGE="https://github.com/sparklemotion/http-cookie"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+
+# See https://github.com/sparklemotion/http-cookie/issues/16 for dropping domain_name
+ruby_add_rdepend ">=dev-ruby/domain_name-0.5:0"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/d" -e "/bundler/d" Rakefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_http_cookie.rb || die
+ ${RUBY} -Ilib test/test_http_cookie_jar.rb || die
+}