summaryrefslogtreecommitdiff
path: root/dev-ruby/http-cookie/http-cookie-1.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/http-cookie/http-cookie-1.0.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/http-cookie/http-cookie-1.0.3.ebuild')
-rw-r--r--dev-ruby/http-cookie/http-cookie-1.0.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/http-cookie/http-cookie-1.0.3.ebuild b/dev-ruby/http-cookie/http-cookie-1.0.3.ebuild
new file mode 100644
index 000000000000..bfe28e12bd59
--- /dev/null
+++ b/dev-ruby/http-cookie/http-cookie-1.0.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby library to handle HTTP cookies"
+HOMEPAGE="https://github.com/sparklemotion/http-cookie"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/domain_name-0.5:0"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/d" -e "/bundler/d" Rakefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_http_cookie.rb || die
+ ${RUBY} -Ilib test/test_http_cookie_jar.rb || die
+}