summaryrefslogtreecommitdiff
path: root/dev-ruby/html2haml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/html2haml
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/html2haml')
-rw-r--r--dev-ruby/html2haml/Manifest3
-rw-r--r--dev-ruby/html2haml/html2haml-2.2.0.ebuild35
-rw-r--r--dev-ruby/html2haml/metadata.xml11
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-ruby/html2haml/Manifest b/dev-ruby/html2haml/Manifest
new file mode 100644
index 000000000000..f616c5ef0e5c
--- /dev/null
+++ b/dev-ruby/html2haml/Manifest
@@ -0,0 +1,3 @@
+DIST html2haml-2.2.0.gem 21504 BLAKE2B ead2c636baacb8dbba7bd650356da5e2ebfa8ab565edb38ab03df287d8d0709b9271ef3f46fae0f2d2b86d37dbf6a0212fbf6803aaf7757a9f2653b773e46482 SHA512 b6988182073f35d4d9b9f07f2cc2ba01c66679fa646fd2d1e3c8cf0643c88b04a2b1a36d584bdcca897f804e32486a618abc8fbd8db023ff9c22ee66d93ed9f0
+EBUILD html2haml-2.2.0.ebuild 779 BLAKE2B cf8b8151cd0161ae82b3faf3e1311fb8ee7109c675dfc5e74021f336c9c1a3ee52f9c19d9a6a66826b7db1fc036845b81e8a8ce5f0965a62638f5ab2844ecb3b SHA512 27d1d654baf0a310011cc9176824a63f4396df1c801b74049d7448e69354880b5ae36464345b3f75ae349307fa96e35a9c85b5cc1a198225be67952ee977a79e
+MISC metadata.xml 330 BLAKE2B 5f142ee3520e2700e3a51713054c5be0819c6f35d211580d56c8473edcc8f16e1a145bf617bd038bf8727f942b71c3b7e79d7c5cb1ed01b75d24bda2c1866b2c SHA512 b1a1422d9a51ba4512a0ca500213b5d26f6fc3403782a6adf2efa970407273b9ee9cbdde4a44775a9c72c5581df739c8ea8b8a8c77426358b9d5f9694e22800d
diff --git a/dev-ruby/html2haml/html2haml-2.2.0.ebuild b/dev-ruby/html2haml/html2haml-2.2.0.ebuild
new file mode 100644
index 000000000000..fd22986128c1
--- /dev/null
+++ b/dev-ruby/html2haml/html2haml-2.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_EXTRADOC="README.md Changelog.markdown"
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Convert HTML and HTML+Erb to Haml"
+HOMEPAGE="https://github.com/haml/html2haml"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/nokogiri-1.6.0
+ >=dev-ruby/erubis-2.7.0
+ >=dev-ruby/ruby_parser-3.5
+ >=dev-ruby/haml-4.0.0 <dev-ruby/haml-6"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest:0 )"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" test/test_helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test test/html2haml_test.rb || die
+ ${RUBY} -Ilib:test test/erb_test.rb || die
+}
diff --git a/dev-ruby/html2haml/metadata.xml b/dev-ruby/html2haml/metadata.xml
new file mode 100644
index 000000000000..84830dfa406a
--- /dev/null
+++ b/dev-ruby/html2haml/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">haml/html2haml</remote-id>
+ </upstream>
+</pkgmetadata>