summaryrefslogtreecommitdiff
path: root/dev-ruby/html-pipeline
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-17 14:31:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-17 14:31:38 +0100
commit9c26151d84a72781f240cc7ca3e2f0ab4ba60f74 (patch)
tree4ac39398cd519351bf12c6357e7474c508f19d13 /dev-ruby/html-pipeline
parentb99d693f4d27fe2eb2237a0fe7e9c3b87d4d6df5 (diff)
gentoo auto-resync : 17:07:2022 - 14:31:38
Diffstat (limited to 'dev-ruby/html-pipeline')
-rw-r--r--dev-ruby/html-pipeline/Manifest3
-rw-r--r--dev-ruby/html-pipeline/html-pipeline-2.14.2.ebuild42
-rw-r--r--dev-ruby/html-pipeline/metadata.xml11
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-ruby/html-pipeline/Manifest b/dev-ruby/html-pipeline/Manifest
new file mode 100644
index 000000000000..59617a9e4888
--- /dev/null
+++ b/dev-ruby/html-pipeline/Manifest
@@ -0,0 +1,3 @@
+DIST html-pipeline-2.14.2.tar.gz 39691 BLAKE2B 156b73b1ff2efe9495556b24a5e0b607386ba944e239f3748e9224024d8bcce6f51f54d50db36499a2fbebb083b064f84f62af335576dfafab0554e8e4259204 SHA512 6782295364f9dae304e1044827bd594c742257903f48f78fbcac4359c6596c506bf3028c9d3c33116f1971a568c4aa2de72689c576ab0576ffdda438c6497de6
+EBUILD html-pipeline-2.14.2.ebuild 1117 BLAKE2B 40c05b285783ee77dcb47326266e12d1bcd6d11388ce5bdf769767e71dbb2db040c7a0d895d30e9ce9f276a0514807d9c2ecf2797005b5eb121490da0f52264c SHA512 5d1368e4e048b35f37853c7ee5f92d20a4e4894bdb40dee82843cb2a867cb241f9e0b67f1cb88b3a54d88adfd4c16bf0a796d23269bb1b09ab3d66b772d506c2
+MISC metadata.xml 341 BLAKE2B 9cbe605182f3daa099064c715d545ec79a48afd90fefde964aeaab480308cc2d668a4655217fe8db21719b4a306bb3ad515f8b7ab9e6179e1e9d45810853724c SHA512 6312a037c8b640210680bff1f5e1d238e5497b6f28d3dfe16b4cc8faa1f38f0de45181d8bec4577afeba12aab75c435866c0e0151170cc55ce5b4c7c607a94ac
diff --git a/dev-ruby/html-pipeline/html-pipeline-2.14.2.ebuild b/dev-ruby/html-pipeline/html-pipeline-2.14.2.ebuild
new file mode 100644
index 000000000000..2f0ed5becc11
--- /dev/null
+++ b/dev-ruby/html-pipeline/html-pipeline-2.14.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="html-pipeline.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="GitHub HTML processing filters and utilities"
+HOMEPAGE="https://github.com/gjtorikian/html-pipeline"
+SRC_URI="https://github.com/gjtorikian/html-pipeline/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/activesupport-2:*
+ >=dev-ruby/nokogiri-1.4
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/commonmarker
+ dev-ruby/rinku
+ dev-ruby/redcloth
+ dev-ruby/rouge
+ dev-ruby/sanitize
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/\(bundler\|focus\)/ s:^:#:' Rakefile test/test_helper.rb || die
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid running tests for unpackaged optional dependencies
+ # escape_utils, email_reply_parser, gemoji
+ rm -f test/html/pipeline/{email_reply,emoji,plain_text_input,syntax_highlight,toc}_filter_test.rb || die
+}
diff --git a/dev-ruby/html-pipeline/metadata.xml b/dev-ruby/html-pipeline/metadata.xml
new file mode 100644
index 000000000000..53fbb8157b7e
--- /dev/null
+++ b/dev-ruby/html-pipeline/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">gjtorikian/html-pipeline</remote-id>
+ </upstream>
+</pkgmetadata>