summaryrefslogtreecommitdiff
path: root/dev-ruby/hoe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /dev-ruby/hoe
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'dev-ruby/hoe')
-rw-r--r--dev-ruby/hoe/Manifest2
-rw-r--r--dev-ruby/hoe/hoe-3.17.2.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-ruby/hoe/Manifest b/dev-ruby/hoe/Manifest
index bd2598931176..c2ddec2242a8 100644
--- a/dev-ruby/hoe/Manifest
+++ b/dev-ruby/hoe/Manifest
@@ -1,5 +1,7 @@
DIST hoe-3.16.0.gem 188416 BLAKE2B 48383c46512a359a269ca3475ec701b1443e0ef71b31d1ca1604de391ed4df6b0ad27dd1c5f6ed04751047d211f2c6299245361cf131e2418f224324ac9934c3 SHA512 66cefb5a24906e19bbf0c82c8539d6d101b84d0dc1d3ce1910e4117357639489968271e76e86bd3c432b9ef7e3b24a78294c06210cbef280860f7dac18100606
DIST hoe-3.17.1.gem 188416 BLAKE2B 0fef6dd9ae4bda93f527d7451d0d591cdc4ba1361aaec531f82e0d7ff03575845c3d5ff85189d76f9ecec17797774fd0ca82f7332a4588d086a494095af99a9d SHA512 5e4b83309ed88da098a5ae8698f9686cea1657f4554fff72446bac46bc567125232a3c5a5b941bd6d5ea18dc53f3cbf5b329f2f0623ef74e81d81586edc63ca3
+DIST hoe-3.17.2.gem 188416 BLAKE2B a6f4f93cc2d724b1c1e855c4e6976b5dbb469c4e10fc9c181b6cafaeb7088f9c19bd4bb5b858a25f011dead1b6e8392d349fe9e86d704a6a4d627cddab8de46a SHA512 d6703cd8913ac7055c33dbfead5610bd197be90ac3aeeaf2e4498ab088447d7e08dbe1ad3fdc602afd26fc7cfda12d73dd43a605b9bf59ecd83b1cfd8845f55b
EBUILD hoe-3.16.0.ebuild 1519 BLAKE2B 764738ca5d9c9e9b5594d5ba663b9b4c8bf904dc586662b44e36d8a697e8abda3bc5b0ffd7aaf05ac0eb1abbac3bb85458d79b196217da6f9df81d5a6744831a SHA512 7d846277053b5fc31f3967388833cb16e7d95481857e2154798dcef672f8d335d729a89203bac1c45e8b0c6531c782d3bf0669854441ca929eaa3d743c273b90
EBUILD hoe-3.17.1.ebuild 1526 BLAKE2B f146316ab2273ecbd963acf2a53d69be268d0e8d37b0fd0c3fe120028a656e26c1e375940aa2956074b77fc91cd43ddccec4f8c0f21fd6269f8bd4c1e0e9bb61 SHA512 55d39bdd286085c669ab0d2063b28a30213560ca2119011546705372ababc305357f1bcb984acad186a8811f73d6aca81d98413eb98a7d3310c22e86b98a42f8
+EBUILD hoe-3.17.2.ebuild 1533 BLAKE2B e9501728a35520ffc525df76dd5a8b396e5741c4314975418b1585ec8ffe06b5abb75fa5c58990be581d1360cdff85db6cbab31dc4e22080c351d4ab349cdfd3 SHA512 9c676473a653a5dc9a40756c039bf539e33f678304433918d2f0d1ec1d1c16abe289508bcae850489130852e2ab1459d4c2bf12378fbb5b6b7bb7db69e52d651
MISC metadata.xml 251 BLAKE2B e8bf2b70161d425791d65052583fd8be03b19ef3bb2a2cde34605bc93224fea9d8c6a91f0f2d630a00094ef54c0871e210da0e0134f52401bc80cb6b2358c13d SHA512 17d4dbd64468a524311a24ca065537a5b21560388efd282f3fa873e6722f70db6f83e3e5615556450905c29d5df2cf0a0855f9c0b38bf23f0f8112501456d4ea
diff --git a/dev-ruby/hoe/hoe-3.17.2.ebuild b/dev-ruby/hoe/hoe-3.17.2.ebuild
new file mode 100644
index 000000000000..daae06b70ab2
--- /dev/null
+++ b/dev-ruby/hoe/hoe-3.17.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc Manifest.txt README.rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="template"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hoe extends rake to provide full project automation"
+HOMEPAGE="https://www.zenspider.com/projects/hoe.html"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.9:5 )"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.7 <dev-ruby/rake-13.0"
+
+all_ruby_prepare() {
+ # Skip isolation
+ sed -i -e '/isolate/ s:^:#:' Rakefile || die
+
+ # Skip test depending on specifics of gem command name
+ sed -i -e '/test_nosudo/,/^ end/ s:^:#:' test/test_hoe.rb || die
+
+ # Gem.bin_wrapper does not work as expected on Gentoo.
+ sed -i -e 's/#{Gem.bin_wrapper "rdoc"}/-S rdoc/' lib/hoe/rcov.rb lib/hoe/publish.rb test/test_hoe_publish.rb || die
+
+ # Avoid test with random sort order
+ sed -i -e '/test_possibly_better/askip "ordering issues"' test/test_hoe.rb || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc; then
+ rdoc --title "seattlerb's hoe-3.5.1 Documentation" -o doc --main README.txt lib History.txt Manifest.txt README.txt || die
+ fi
+}