summaryrefslogtreecommitdiff
path: root/dev-ruby/hocon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /dev-ruby/hocon
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'dev-ruby/hocon')
-rw-r--r--dev-ruby/hocon/Manifest4
-rw-r--r--dev-ruby/hocon/hocon-1.2.6.ebuild24
-rw-r--r--dev-ruby/hocon/hocon-1.3.0.ebuild24
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-ruby/hocon/Manifest b/dev-ruby/hocon/Manifest
index 22b87119b655..728de34311cf 100644
--- a/dev-ruby/hocon/Manifest
+++ b/dev-ruby/hocon/Manifest
@@ -1,3 +1,7 @@
DIST hocon-1.2.5.gem 147968 BLAKE2B 9fe004d59cc3e66d770c7c8069ff2934a17befa120ccfb2e382f36f632a186095c3a94eb25e77ba3fff422394444ae85cf3adde2ed045d50f0ac99871c6dd909 SHA512 7d2d86c28edd6ed6dd99358558093cd224b9922bcbcdd2e95e23134ef0e9a2bae6129e7273435032850b672094e77f8f5b6d8cfeec03762b39ed6b63fc5fb5dd
+DIST hocon-1.2.6.tar.gz 145888 BLAKE2B 743b58d156e046e8226aec7d616bc4a8f6a044687270d50c7e618dde890927293bf750e6d4cbc0f394d1bd9b089c751f30aa08685026dab658efad1313b54d1c SHA512 dbc48fc1c895ee3278431e4dd6bb6b8a84f50bb630a768cc1fa295440d7d057c0eb72ab54d9ed35d397bbeb0febf110586a7d641d91b6898100ab7bf7b2a9001
+DIST hocon-1.3.0.tar.gz 146291 BLAKE2B c7104cd7fa2621ef5e39148de6e67c1b272153ae1b39dc5558b38202b5315f600f2933c19b6e075a5344bb215ba7ddaf95a73e0980cd3ff006dc67437b10823d SHA512 67a69b516197b4a0e64c275fe4b930a3b1128ef1949c47263ba9a20bd8397152a2a5dce0c64ce54dbcf7bd3c81d77aa2fb450e12f5aa7bacb0c85e61083904f6
EBUILD hocon-1.2.5.ebuild 539 BLAKE2B 242287c7614b6897ac0115d10f9ec29c4337e76f0b92cb539ba201ef8cb76daa978c62586477f3a4badfed659bbe106bb06aa83eede80980764c3015c00ae4ba SHA512 698340fa9cedb40faf187c1fd89b46e14f889024ea8dd2c0c1447f312a46e60d4d804ba8ca92bddc92eaae982a6ad8b5883b6c3c70b7c709c2db0e374e0fdf97
+EBUILD hocon-1.2.6.ebuild 630 BLAKE2B 0c89d6137187dbb05fba73e35cbefc660ccc99cb43af8400db13dc008487eefa8f19136757de9929025b950a69347bed653a59c85052ea22f70acb1cb64f59d9 SHA512 0719c2149983e006e9daeb061d27a7e9ef77358eb1f1ec554cd124e333b5d80875d3df2429cdb543da4ae348f89c8e93569c571868113e9bbd850561428253fc
+EBUILD hocon-1.3.0.ebuild 630 BLAKE2B 0c89d6137187dbb05fba73e35cbefc660ccc99cb43af8400db13dc008487eefa8f19136757de9929025b950a69347bed653a59c85052ea22f70acb1cb64f59d9 SHA512 0719c2149983e006e9daeb061d27a7e9ef77358eb1f1ec554cd124e333b5d80875d3df2429cdb543da4ae348f89c8e93569c571868113e9bbd850561428253fc
MISC metadata.xml 514 BLAKE2B 41c8fb2854ca091452e2530a98518581287253088bc3709b9945a47ca1ad06ffeb4ef40a1da8e2843322fde51e805e381a768a8cf3fd14b5d62d660fe975a59e SHA512 cfd1c8e9f9eaf4f3cf797e9fb40bdeee6004a38e1d3dac66469dc43944204722720c63798671d3032034dd826f44075257db43021910d31af3333df423064ba3
diff --git a/dev-ruby/hocon/hocon-1.2.6.ebuild b/dev-ruby/hocon/hocon-1.2.6.ebuild
new file mode 100644
index 000000000000..c9a3580f249f
--- /dev/null
+++ b/dev-ruby/hocon/hocon-1.2.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_BINWRAP="hocon"
+
+RUBY_FAKEGEM_GEMSPEC="hocon.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This is a port of the Typesafe Config library to Ruby."
+HOMEPAGE="https://github.com/puppetlabs/ruby-hocon"
+SRC_URI="https://github.com/puppetlabs/ruby-hocon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-hocon-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
diff --git a/dev-ruby/hocon/hocon-1.3.0.ebuild b/dev-ruby/hocon/hocon-1.3.0.ebuild
new file mode 100644
index 000000000000..c9a3580f249f
--- /dev/null
+++ b/dev-ruby/hocon/hocon-1.3.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_BINWRAP="hocon"
+
+RUBY_FAKEGEM_GEMSPEC="hocon.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This is a port of the Typesafe Config library to Ruby."
+HOMEPAGE="https://github.com/puppetlabs/ruby-hocon"
+SRC_URI="https://github.com/puppetlabs/ruby-hocon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-hocon-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"