summaryrefslogtreecommitdiff
path: root/dev-ruby/hiera/hiera-3.4.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-21 18:00:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-21 18:00:10 +0100
commit265dbe5dbc14c199299496c6db8fce3f76647015 (patch)
treeab18b5617d138f6684566b619405090989d55a2c /dev-ruby/hiera/hiera-3.4.5.ebuild
parent586819755b4dbfdffdc8a725ab7c0f86095b8489 (diff)
gentoo resync : 21.09.2018
Diffstat (limited to 'dev-ruby/hiera/hiera-3.4.5.ebuild')
-rw-r--r--dev-ruby/hiera/hiera-3.4.5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/hiera/hiera-3.4.5.ebuild b/dev-ruby/hiera/hiera-3.4.5.ebuild
new file mode 100644
index 000000000000..f653c3e47f1f
--- /dev/null
+++ b/dev-ruby/hiera/hiera-3.4.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple pluggable Hierarchical Database"
+HOMEPAGE="https://docs.puppet.com/hiera/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+ruby_add_bdepend "test? ( dev-ruby/mocha )"
+
+ruby_add_rdepend "dev-ruby/deep_merge"