summaryrefslogtreecommitdiff
path: root/dev-ruby/hiera/hiera-3.11.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-11 09:22:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-11 09:22:24 +0000
commit583acea08c150460a36d3ee1a4800c33b9b19103 (patch)
tree9152116a16df0b23202b077b54a014f7d2c28373 /dev-ruby/hiera/hiera-3.11.0.ebuild
parentecd86b32a8f0b6be58bbb4b294ce38f1fbd7d3dc (diff)
gentoo auto-resync : 11:12:2022 - 09:22:24
Diffstat (limited to 'dev-ruby/hiera/hiera-3.11.0.ebuild')
-rw-r--r--dev-ruby/hiera/hiera-3.11.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/hiera/hiera-3.11.0.ebuild b/dev-ruby/hiera/hiera-3.11.0.ebuild
new file mode 100644
index 000000000000..c22010b56757
--- /dev/null
+++ b/dev-ruby/hiera/hiera-3.11.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple pluggable Hierarchical Database"
+HOMEPAGE="https://docs.puppet.com/hiera/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+ruby_add_bdepend "test? ( dev-ruby/mocha )"
+
+ruby_add_rdepend "dev-ruby/deep_merge"