summaryrefslogtreecommitdiff
path: root/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0.ebuild')
-rw-r--r--dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0.ebuild b/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0.ebuild
new file mode 100644
index 000000000000..012ab7aa143c
--- /dev/null
+++ b/dev-ruby/heredoc_unindent/heredoc_unindent-1.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+inherit ruby-fakegem
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
+DESCRIPTION="Removes leading whitespace from Ruby heredocs"
+HOMEPAGE="https://github.com/adrianomitre/heredoc_unindent"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/hoe-2.8.0 dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '1igem "test-unit"' test/test_heredoc_unindent.rb || die
+}