summaryrefslogtreecommitdiff
path: root/dev-ruby/haml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-ruby/haml
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-ruby/haml')
-rw-r--r--dev-ruby/haml/Manifest3
-rw-r--r--dev-ruby/haml/haml-5.1.2-r1.ebuild58
-rw-r--r--dev-ruby/haml/haml-5.1.2.ebuild4
3 files changed, 62 insertions, 3 deletions
diff --git a/dev-ruby/haml/Manifest b/dev-ruby/haml/Manifest
index 0d10da6f1b62..e56c420099dc 100644
--- a/dev-ruby/haml/Manifest
+++ b/dev-ruby/haml/Manifest
@@ -1,3 +1,4 @@
DIST haml-5.1.2.tar.gz 126059 BLAKE2B 5d805f29c28d0f6355f7b79e5724ec1639a808cfae75c26633edddcc82d964a48dbc1654b780fb706529ca22abcaba953a1af6f483386c336035c079a719e585 SHA512 405976de297bfdbd6f010442d940205c404f057a54cd7162feb400b1831af3e4e60fd05a637a2f480204428512ca7dd66c02aca22b0006d6d515c06968eb08a3
-EBUILD haml-5.1.2.ebuild 1665 BLAKE2B 7c556530f3f0025a063044f9b6ddddd995c2cb66c8fc9bf8006e2acfbaff162063d70444f477f951e87568ff0acc1655d439f521d5937e65b8ff2bab17e7a58d SHA512 7840f679c227db74c26c0df4a6eda77108d6929d0a24f0a482a39a925efe9754b693f51bdad283357ede548bd9886fd071ebbc1d0e76f2b446e521874fa619e4
+EBUILD haml-5.1.2-r1.ebuild 1680 BLAKE2B cb73b65a6f73e3e555a34b4f59800ef7338eb3ef0ac3e40b9b64b6252781b1f715b4bf9ceb2a12fdec6bdbcd5830b2f5efd3b72cc388d8333e1dab180d24e809 SHA512 06ca53ab7ed464657aed8c5b4c09d7357ac47e58f9f38c922d4addf257e3d7e16506244fab6328112f93e8004f675bdee49ea02abe97d894b937e251095e1f19
+EBUILD haml-5.1.2.ebuild 1659 BLAKE2B e9a2581d41907f0b6a587829ce8243e57c9f4582ad09f4e90eeaf02bcddf2704c9f96a0a384a14cefb9b4a1d93979df7a398cf7e69d1bd7e7b9bb42ed9b34aae SHA512 dba0fa00d2eb9b29acdcb2e707132b9a8f23a25e254cce611e04dad239eb8f8f885801cf52212880105f176fa96a0ac7e31337d3c59f2cf38a528855db241d38
MISC metadata.xml 247 BLAKE2B 7717702c51c35b2a20983332abc6218047b2b5036e6b4c09d3d58b4339e8f9e776879cd116cfda60d3bcf4188859993fb9f3f779aaf595f155d53e85288f3dcc SHA512 ea4c044637b751a2c28c6ac226121e74ef18196af4b594e60413fec907bbab29c6b0c7735c3f503485df16dcfb36ddb86038394d92e2cd18c8f04626628e9f09
diff --git a/dev-ruby/haml/haml-5.1.2-r1.ebuild b/dev-ruby/haml/haml-5.1.2-r1.ebuild
new file mode 100644
index 000000000000..b90ecb0360da
--- /dev/null
+++ b/dev-ruby/haml/haml-5.1.2-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_TEST="MT_NO_PLUGINS=true test"
+RUBY_FAKEGEM_TASK_DOC="-Ilib doc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md REFERENCE.md"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby web page templating engine"
+HOMEPAGE="https://haml.info/"
+SRC_URI="https://github.com/haml/haml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="doc test"
+
+RDEPEND="${RDEPEND} !!<dev-ruby/haml-4.0.7-r2"
+
+ruby_add_rdepend ">=dev-ruby/temple-0.8.0 dev-ruby/tilt:*"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/minitest:5
+ dev-ruby/nokogiri
+ dev-ruby/railties:6.0
+ dev-ruby/activemodel:6.0
+ dev-ruby/actionpack:6.0
+ )
+ doc? (
+ dev-ruby/yard
+ >=dev-ruby/maruku-0.7.2-r1
+ )"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find . -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -i -e '/bundler/ s:^:#: ; /Bundler/,/end/ s:^:#:' Rakefile || die
+ sed -i -e '/bundler/I s:^:#:' \
+ -e 's/gem "minitest"/gem "minitest", "~>5.0"/'\
+ -e '1igem "actionpack", "~>6.0.0"'\
+ -e '1igem "activesupport", "~>6.0.0"; gem "activemodel", "~>6.0.0"'\
+ -e '1igem "railties", "~>6.0.0"'\
+ test/test_helper.rb || die
+ # Remove test that fails when RedCloth is available
+ sed -i -e "/should raise error when a Tilt filters dependencies are unavailable for extension/,/^ end/ s/^/#/"\
+ test/filters_test.rb || die
+}
diff --git a/dev-ruby/haml/haml-5.1.2.ebuild b/dev-ruby/haml/haml-5.1.2.ebuild
index 0d3672e4848a..19f6f3fbb573 100644
--- a/dev-ruby/haml/haml-5.1.2.ebuild
+++ b/dev-ruby/haml/haml-5.1.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26"
+USE_RUBY="ruby25 ruby26"
RUBY_FAKEGEM_TASK_TEST="MT_NO_PLUGINS=true test"
RUBY_FAKEGEM_TASK_DOC="-Ilib doc"
@@ -16,7 +16,7 @@ RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
inherit ruby-fakegem
DESCRIPTION="A ruby web page templating engine"
-HOMEPAGE="http://haml.info/"
+HOMEPAGE="https://haml.info/"
SRC_URI="https://github.com/haml/haml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"