summaryrefslogtreecommitdiff
path: root/dev-ruby/haml/haml-6.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-24 13:37:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-24 13:37:40 +0000
commitba4938837d52c0aff763d8acdc03ce103dd3ff82 (patch)
tree377739d379f8040dc456a89b2347a8f2a83830c8 /dev-ruby/haml/haml-6.3.0.ebuild
parent3e3aa158fd100df495010eed7915f012d5c9bcaa (diff)
gentoo auto-resync : 24:12:2023 - 13:37:40
Diffstat (limited to 'dev-ruby/haml/haml-6.3.0.ebuild')
-rw-r--r--dev-ruby/haml/haml-6.3.0.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-ruby/haml/haml-6.3.0.ebuild b/dev-ruby/haml/haml-6.3.0.ebuild
index a4ac5c0cb899..1f9d7e635988 100644
--- a/dev-ruby/haml/haml-6.3.0.ebuild
+++ b/dev-ruby/haml/haml-6.3.0.ebuild
@@ -49,6 +49,12 @@ all_ruby_prepare() {
test/test_helper.rb || die
# Remove tests that fails when RedCloth is available
rm -f test/haml/filters/markdown_test.rb || die
+
+ # Remove tests that require coffee-script (does not work with x32
+ # and coffee-script is obsolete anyway).
+ rm -f test/haml/filters/coffee_test.rb || die
+ sed -e '/describe.*coffee filter/,/^ end/ s:^:#:' \
+ -i test/haml/line_number_test.rb || die
}
each_ruby_test() {