summaryrefslogtreecommitdiff
path: root/dev-ruby/haml/haml-4.0.7-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-02 17:13:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-02 17:13:10 +0100
commit0bff53119f08d677db6c1a991bd30741682a8a08 (patch)
tree6ec8d4c38152bb4f2bb4b93277236ebd9fbbd21d /dev-ruby/haml/haml-4.0.7-r2.ebuild
parent6c14fa2586d9e9c4427b5f727dc6c8ab77587cec (diff)
Revert "gentoo resync : 02.06.2018"
This reverts commit 6c14fa2586d9e9c4427b5f727dc6c8ab77587cec.
Diffstat (limited to 'dev-ruby/haml/haml-4.0.7-r2.ebuild')
-rw-r--r--dev-ruby/haml/haml-4.0.7-r2.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-ruby/haml/haml-4.0.7-r2.ebuild b/dev-ruby/haml/haml-4.0.7-r2.ebuild
deleted file mode 100644
index f2c698f635d3..000000000000
--- a/dev-ruby/haml/haml-4.0.7-r2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_TASK_TEST="test"
-RUBY_FAKEGEM_TASK_DOC="-Ilib doc"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md REFERENCE.md"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="A ruby web page templating engine"
-HOMEPAGE="http://haml-lang.com/"
-
-LICENSE="MIT"
-SLOT="4"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-IUSE="doc test"
-
-RDEPEND="${RDEPEND} !!<dev-ruby/haml-3.1.8-r2"
-
-ruby_add_rdepend "dev-ruby/tilt:*"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/minitest:5
- dev-ruby/nokogiri
- dev-ruby/rails:4.2
- dev-ruby/bundler
- )
- doc? (
- dev-ruby/yard
- >=dev-ruby/maruku-0.7.2-r1
- )"
-
-all_ruby_prepare() {
- # Remove test that fails when RedCloth is available
- sed -i -e "/should raise error when a Tilt filters dependencies are unavailable for extension/,+9 s/^/#/"\
- test/filters_test.rb || die
- # Avoid tests that are fragile for whitespace
- sed -i -e '/test_\(text_area\|partials_should_not_cause_textareas\)/,/^ end/ s:^:#:' test/helper_test.rb || die
-}