summaryrefslogtreecommitdiff
path: root/dev-ruby/google-protobuf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /dev-ruby/google-protobuf
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'dev-ruby/google-protobuf')
-rw-r--r--dev-ruby/google-protobuf/Manifest3
-rw-r--r--dev-ruby/google-protobuf/google-protobuf-3.6.1.ebuild37
-rw-r--r--dev-ruby/google-protobuf/metadata.xml8
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-ruby/google-protobuf/Manifest b/dev-ruby/google-protobuf/Manifest
new file mode 100644
index 000000000000..e96a989e88de
--- /dev/null
+++ b/dev-ruby/google-protobuf/Manifest
@@ -0,0 +1,3 @@
+DIST google-protobuf-3.6.1-ruby.tar.gz 4485582 BLAKE2B 546c49759df784018459809b9db692c5c94aef5d717183af5cd9edd96b4c658e759f23950cdcd5dddceaaad06ea1de2a2357b9fa8c496ed5d538fc5920174da0 SHA512 1bc175d24b49de1b1e41eaf39598194e583afffb924c86c8d2e569d935af21874be76b2cbd4d9655a1d38bac3d4cd811de88bc2c72d81bad79115e69e5b0d839
+EBUILD google-protobuf-3.6.1.ebuild 905 BLAKE2B b9af584f19a244535574ef187d5b5effd8cd823d96c4706c00cb7ef0c29ef81c258c62e89c5c23975a35ce26ad79abff2bd6ff34444479568525941a134ca830 SHA512 b18c47f7915fe1607568d9dbf0c159afecad4e84b7197cf1748e4ca6ef05e71ad85f001b29e172d8a4ccb4cd3be4103b7f4b2acdc458b02e94b74dff9a497a72
+MISC metadata.xml 247 BLAKE2B 7717702c51c35b2a20983332abc6218047b2b5036e6b4c09d3d58b4339e8f9e776879cd116cfda60d3bcf4188859993fb9f3f779aaf595f155d53e85288f3dcc SHA512 ea4c044637b751a2c28c6ac226121e74ef18196af4b594e60413fec907bbab29c6b0c7735c3f503485df16dcfb36ddb86038394d92e2cd18c8f04626628e9f09
diff --git a/dev-ruby/google-protobuf/google-protobuf-3.6.1.ebuild b/dev-ruby/google-protobuf/google-protobuf-3.6.1.ebuild
new file mode 100644
index 000000000000..bc07705fb0cf
--- /dev/null
+++ b/dev-ruby/google-protobuf/google-protobuf-3.6.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Protocol Buffers are Google's data interchange format"
+HOMEPAGE="https://developers.google.com/protocol-buffers"
+SRC_URI="https://github.com/protocolbuffers/protobuf/archive/v${PV}.tar.gz -> ${P}-ruby.tar.gz"
+RUBY_S="protobuf-${PV}/ruby"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND+=" test? ( dev-libs/protobuf )"
+
+each_ruby_prepare() {
+ sed -i -e 's:../src/protoc:protoc: ; /^task :build/ s/:compile,//' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/google/protobuf_c extconf.rb
+}
+
+each_ruby_compile() {
+ emake -Cext/google/protobuf_c V=1
+ cp ext/google/protobuf_c/protobuf_c.so lib/google/ || die
+}
diff --git a/dev-ruby/google-protobuf/metadata.xml b/dev-ruby/google-protobuf/metadata.xml
new file mode 100644
index 000000000000..28ab0c15f206
--- /dev/null
+++ b/dev-ruby/google-protobuf/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+</maintainer>
+</pkgmetadata>