summaryrefslogtreecommitdiff
path: root/dev-ruby/google-protobuf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
commit2018227e9344edb9da15fc6a4a8298086cc2aa77 (patch)
treec18e1c09e605e94e2a1e93345ad25746cc9e14b9 /dev-ruby/google-protobuf
parent6f8038813c460b4f0572d5ef595cdfa94af3a94d (diff)
gentoo resync : 02.06.2019
Diffstat (limited to 'dev-ruby/google-protobuf')
-rw-r--r--dev-ruby/google-protobuf/Manifest2
-rw-r--r--dev-ruby/google-protobuf/google-protobuf-3.8.0.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/google-protobuf/Manifest b/dev-ruby/google-protobuf/Manifest
index e96a989e88de..5dbe07d0edd3 100644
--- a/dev-ruby/google-protobuf/Manifest
+++ b/dev-ruby/google-protobuf/Manifest
@@ -1,3 +1,5 @@
DIST google-protobuf-3.6.1-ruby.tar.gz 4485582 BLAKE2B 546c49759df784018459809b9db692c5c94aef5d717183af5cd9edd96b4c658e759f23950cdcd5dddceaaad06ea1de2a2357b9fa8c496ed5d538fc5920174da0 SHA512 1bc175d24b49de1b1e41eaf39598194e583afffb924c86c8d2e569d935af21874be76b2cbd4d9655a1d38bac3d4cd811de88bc2c72d81bad79115e69e5b0d839
+DIST google-protobuf-3.8.0-ruby.tar.gz 4934577 BLAKE2B 4b86ab216e8a8b2c99c3620da9417c0562498e9d4dbf4957db186f51c62b0ed73b1322635a076b2d4054e015bdf6c8c50cc7fd0cb78d24a93b29d2a5b48f66fe SHA512 ba27c64e5193cd4a144bf0c9dc0d195fbbe6e580aaca01960362f0f185074588ca40046d3bcea76e1deae7508b722f6c5be484ea957122ae8e98229c7c3a4ad2
EBUILD google-protobuf-3.6.1.ebuild 905 BLAKE2B b9af584f19a244535574ef187d5b5effd8cd823d96c4706c00cb7ef0c29ef81c258c62e89c5c23975a35ce26ad79abff2bd6ff34444479568525941a134ca830 SHA512 b18c47f7915fe1607568d9dbf0c159afecad4e84b7197cf1748e4ca6ef05e71ad85f001b29e172d8a4ccb4cd3be4103b7f4b2acdc458b02e94b74dff9a497a72
+EBUILD google-protobuf-3.8.0.ebuild 913 BLAKE2B 8e1ea1aad0db1207f3c82e7065f28ee19cfe5cdffff91fb75113bb5963830d67c71c8be1b45e85fed77036d579a203775eabc207ff5ea5dbd9fd28eb638048b4 SHA512 cb217fcb8495f773778fc2e53e56a48828d3390907420c37cb0a711b545a07533ba6145d34ad322a8eb2a2586c94d9f34b32f8bc8624c4b7dca9b5f0b46aad9b
MISC metadata.xml 247 BLAKE2B 7717702c51c35b2a20983332abc6218047b2b5036e6b4c09d3d58b4339e8f9e776879cd116cfda60d3bcf4188859993fb9f3f779aaf595f155d53e85288f3dcc SHA512 ea4c044637b751a2c28c6ac226121e74ef18196af4b594e60413fec907bbab29c6b0c7735c3f503485df16dcfb36ddb86038394d92e2cd18c8f04626628e9f09
diff --git a/dev-ruby/google-protobuf/google-protobuf-3.8.0.ebuild b/dev-ruby/google-protobuf/google-protobuf-3.8.0.ebuild
new file mode 100644
index 000000000000..5eefeb1f2412
--- /dev/null
+++ b/dev-ruby/google-protobuf/google-protobuf-3.8.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Protocol Buffers are Google's data interchange format"
+HOMEPAGE="https://developers.google.com/protocol-buffers"
+SRC_URI="https://github.com/protocolbuffers/protobuf/archive/v${PV}.tar.gz -> ${P}-ruby.tar.gz"
+RUBY_S="protobuf-${PV}/ruby"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND+=" test? ( >=dev-libs/protobuf-3.7.0 )"
+
+each_ruby_prepare() {
+ sed -i -e 's:../src/protoc:protoc: ; /^task :build/ s/:compile,//' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/google/protobuf_c extconf.rb
+}
+
+each_ruby_compile() {
+ emake -Cext/google/protobuf_c V=1
+ cp ext/google/protobuf_c/protobuf_c.so lib/google/ || die
+}