summaryrefslogtreecommitdiff
path: root/dev-ruby/google-protobuf/google-protobuf-3.19.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-08 09:23:49 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-08 09:23:49 +0000
commitf077c725ef746943ec7902350b30ff569f5995ba (patch)
treeac5ad0215e09a9daa3ce0e55095401ead1936ac8 /dev-ruby/google-protobuf/google-protobuf-3.19.6.ebuild
parentb6cda9acfebad17184578dfebaf2434ef2884883 (diff)
gentoo auto-resync : 08:11:2022 - 09:23:49
Diffstat (limited to 'dev-ruby/google-protobuf/google-protobuf-3.19.6.ebuild')
-rw-r--r--dev-ruby/google-protobuf/google-protobuf-3.19.6.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/google-protobuf/google-protobuf-3.19.6.ebuild b/dev-ruby/google-protobuf/google-protobuf-3.19.6.ebuild
new file mode 100644
index 000000000000..c9d9624dd10c
--- /dev/null
+++ b/dev-ruby/google-protobuf/google-protobuf-3.19.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/google/protobuf_c/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR=lib/google
+
+inherit ruby-fakegem
+
+DESCRIPTION="Protocol Buffers are Google's data interchange format"
+HOMEPAGE="https://developers.google.com/protocol-buffers"
+SRC_URI="https://github.com/protocolbuffers/protobuf/archive/v${PV}.tar.gz -> ${P}-ruby.tar.gz"
+RUBY_S="protobuf-${PV}/ruby"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND+=" test? ( >=dev-libs/protobuf-3.19.0 )"
+
+all_ruby_prepare() {
+ sed -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/^ end/ s:^:#:' \
+ -e 's:../src/protoc:protoc:' \
+ -e 's/:compile,//' \
+ -e '/:test/ s/:build,//' \
+ -i Rakefile || die
+}