summaryrefslogtreecommitdiff
path: root/dev-ruby/gnuplot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-ruby/gnuplot
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-ruby/gnuplot')
-rw-r--r--dev-ruby/gnuplot/Manifest1
-rw-r--r--dev-ruby/gnuplot/gnuplot-2.6.2-r3.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/gnuplot/Manifest b/dev-ruby/gnuplot/Manifest
index 95e2dc562643..c0a32b9021c6 100644
--- a/dev-ruby/gnuplot/Manifest
+++ b/dev-ruby/gnuplot/Manifest
@@ -1,3 +1,4 @@
DIST gnuplot-2.6.2.gem 13824 BLAKE2B 5fe89c44bcfc8f73e4685fbf8300b5a43845ed8292db84bf3b21f884656a8cf29623bdef37fd4aebbb54ef1a582567fd2c12029a2e4584a92b52f66dad3b8e4f SHA512 bcc9dbdade4fdcaa590006ca925c4f1eb71b4c7d6235c948266a185c937d991ff559a1749f33993baca4437252afdfa7bde1a43c6e05dc6f180e9e7b06a4a8e6
EBUILD gnuplot-2.6.2-r2.ebuild 742 BLAKE2B 9cd318fec98f1ef784b4eb634b8ccc99e1c40f9caca5fe7d259a2362c70f866c406fa642d0e74be40f99ad2cfa1f450376a53c6dfc1613cad1a4fd38b531bd79 SHA512 0c3b42a42f8cc604090f2eab1fa6a91bd68a28e871429f1836a424e75ef0dd93ce3c8a0a61fd65b2eae74930bf065cc422c4329ca91cbbd600c732d3290985c2
+EBUILD gnuplot-2.6.2-r3.ebuild 742 BLAKE2B 82b1cd9d19b478710a2ac405514393dc00e49f9b86868333465e1045d99761a717fe6b7340b9c3d37b1aa00a7546084260b925ff4a05cd4f6d073eb877e0ff5e SHA512 d345c75d25e2f555094fea5c90a41692fca8760ca1d2ca41d6497509ee69ee8f1b14a810bbf7ad8417364698b0a1ab54ceff1c4f1e3e3494e723b4ad618cab38
MISC metadata.xml 252 BLAKE2B 77e9556ac1d210367a95f4c47816618b685c707cf01d1543d988338e14794fb9ccfb9976ebd11f389db618616d91ee024d8e46dc3a1a356ba7a017a7796b44d1 SHA512 0a970a16d73747993198dd301a3127cef7e65a9f46816b40ca149669ba617826c1d81bac1e5ecf93d16079922964923d37301cd8160f22c823c1ec3b79ee56f1
diff --git a/dev-ruby/gnuplot/gnuplot-2.6.2-r3.ebuild b/dev-ruby/gnuplot/gnuplot-2.6.2-r3.ebuild
new file mode 100644
index 000000000000..8db2219c84e6
--- /dev/null
+++ b/dev-ruby/gnuplot/gnuplot-2.6.2-r3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="AUTHORS.txt ChangeLog README.textile"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Gnuplot drawing library - Ruby Bindings"
+HOMEPAGE="http://rgplot.rubyforge.org/"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+SLOT="0"
+
+RDEPEND+=" sci-visualization/gnuplot"
+
+all_ruby_prepare() {
+ # Existing metadata causes a crash in jruby, so use our own.
+ rm -f ../metadata || die "Unable to remove metadata."
+
+ sed -i -e 's/Config/RbConfig/' test/test_gnuplot.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ctest test_gnuplot.rb || die
+}