summaryrefslogtreecommitdiff
path: root/dev-ruby/gnuplot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/gnuplot
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/gnuplot')
-rw-r--r--dev-ruby/gnuplot/Manifest3
-rw-r--r--dev-ruby/gnuplot/gnuplot-2.6.2-r2.ebuild34
-rw-r--r--dev-ruby/gnuplot/metadata.xml8
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/gnuplot/Manifest b/dev-ruby/gnuplot/Manifest
new file mode 100644
index 000000000000..f0191d50bf17
--- /dev/null
+++ b/dev-ruby/gnuplot/Manifest
@@ -0,0 +1,3 @@
+DIST gnuplot-2.6.2.gem 13824 BLAKE2B 5fe89c44bcfc8f73e4685fbf8300b5a43845ed8292db84bf3b21f884656a8cf29623bdef37fd4aebbb54ef1a582567fd2c12029a2e4584a92b52f66dad3b8e4f SHA512 bcc9dbdade4fdcaa590006ca925c4f1eb71b4c7d6235c948266a185c937d991ff559a1749f33993baca4437252afdfa7bde1a43c6e05dc6f180e9e7b06a4a8e6
+EBUILD gnuplot-2.6.2-r2.ebuild 752 BLAKE2B 3a51923efdac43d36ca4c852b2025ca02be01a2f00cacc624348a39f0518439997c1cda9902f8883d8299aebb126587b834016af6100072217a4d0b860723bb0 SHA512 b5d52d73ac1b9f49667f4dd8c907f7ee1909d18b1025cf64f91036f342c4a4f5cd22d8c5a2ece7543998e7cc43bc7e4d9933504c99e1d5449ed4ae365b624c50
+MISC metadata.xml 251 BLAKE2B e8bf2b70161d425791d65052583fd8be03b19ef3bb2a2cde34605bc93224fea9d8c6a91f0f2d630a00094ef54c0871e210da0e0134f52401bc80cb6b2358c13d SHA512 17d4dbd64468a524311a24ca065537a5b21560388efd282f3fa873e6722f70db6f83e3e5615556450905c29d5df2cf0a0855f9c0b38bf23f0f8112501456d4ea
diff --git a/dev-ruby/gnuplot/gnuplot-2.6.2-r2.ebuild b/dev-ruby/gnuplot/gnuplot-2.6.2-r2.ebuild
new file mode 100644
index 000000000000..7d1de33a1f42
--- /dev/null
+++ b/dev-ruby/gnuplot/gnuplot-2.6.2-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="AUTHORS.txt ChangeLog README.textile"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Gnuplot drawing library - Ruby Bindings"
+HOMEPAGE="http://rgplot.rubyforge.org/"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+SLOT="0"
+
+RDEPEND+=" sci-visualization/gnuplot"
+
+all_ruby_prepare() {
+ # Existing metadata causes a crash in jruby, so use our own.
+ rm -f ../metadata || die "Unable to remove metadata."
+
+ sed -i -e 's/Config/RbConfig/' test/test_gnuplot.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ctest test_gnuplot.rb || die
+}
diff --git a/dev-ruby/gnuplot/metadata.xml b/dev-ruby/gnuplot/metadata.xml
new file mode 100644
index 000000000000..eb1e47f2edfb
--- /dev/null
+++ b/dev-ruby/gnuplot/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+</pkgmetadata>