summaryrefslogtreecommitdiff
path: root/dev-ruby/globalid/globalid-1.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-06 10:25:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-06 10:25:44 +0100
commit64b277f858d171900cba8a53e675ef8c3ff893fc (patch)
tree7a19533ece87b58d4bbcc04d91701aaf888b0d99 /dev-ruby/globalid/globalid-1.2.1.ebuild
parentededf7351b15c0df4d166af8fc7928bd1a0b2c8e (diff)
gentoo auto-resync : 06:09:2023 - 10:25:44
Diffstat (limited to 'dev-ruby/globalid/globalid-1.2.1.ebuild')
-rw-r--r--dev-ruby/globalid/globalid-1.2.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/globalid/globalid-1.2.1.ebuild b/dev-ruby/globalid/globalid-1.2.1.ebuild
new file mode 100644
index 000000000000..e97980eb120e
--- /dev/null
+++ b/dev-ruby/globalid/globalid-1.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="globalid.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Reference models by URI"
+HOMEPAGE="https://github.com/rails/globalid"
+SRC_URI="https://github.com/rails/globalid/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/bundler >=dev-ruby/activemodel-6.1 >=dev-ruby/railties-6.1 )"
+ruby_add_rdepend ">=dev-ruby/activesupport-6.1:*"
+
+all_ruby_prepare() {
+ rm -f Gemfile.lock || die
+}