summaryrefslogtreecommitdiff
path: root/dev-ruby/git
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/git
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/git')
-rw-r--r--dev-ruby/git/Manifest5
-rw-r--r--dev-ruby/git/git-1.3.0.ebuild37
-rw-r--r--dev-ruby/git/git-1.4.0.ebuild33
-rw-r--r--dev-ruby/git/metadata.xml11
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-ruby/git/Manifest b/dev-ruby/git/Manifest
new file mode 100644
index 000000000000..4523f75c81da
--- /dev/null
+++ b/dev-ruby/git/Manifest
@@ -0,0 +1,5 @@
+DIST git-1.3.0.tar.gz 124800 BLAKE2B 7dbdfe19d3398a2ca7df4383c619acca3e9d05875a629dd580286f3e2241e19183b5713daa5c5357f0644ca1570d4ee5a9d81b204ad0546656faa45cf0c99bbc SHA512 a5c86030f20580886b92b0a258cfc5d281d9fb093069c6350d0afb69a9dccb372a257cbbabd415132b35ccd26620bbc3589a5dc6ac1a418f35f42f7d225c9307
+DIST git-1.4.0.tar.gz 125691 BLAKE2B 313cbf5bb6b33d96237fccb01aa691e54ab0e94708ffa582d18c7457196f0438de97a2d03518da219ccde85cae627babdffe1f075d16f113f4b8e98cc00fc9a8 SHA512 270c7cd7485f1fc41bda5e8c11556707b7e807720bce9bfac7f172a9c640d0fb31404ce7d1fa0de8fc743a95adecfb34efae01fbfccb83ccd8a8f0169443a073
+EBUILD git-1.3.0.ebuild 984 BLAKE2B 3d2bd5c042bb9e9f341c5d8ecdf9d5c5a68b6bd05c1d8decbbb2d057566599f1b45f7d17777235b80fc2e0bc3c381c37766064e328b7bbac5889dd625c221a4d SHA512 b4304faf2c0a890da26d10c5e6cc118c6d10907fab5f4143f2860f786adf3ec18d179ac614f9a4d74855640ec71626b4bae4d5f15931f80f469486e21d6e9920
+EBUILD git-1.4.0.ebuild 842 BLAKE2B 5f46c3fed8598be54ebed531ea9cd72b92c3074aa6d1981cc8fa650b61eb05a412b090797c440c825a6b437d2898874c55467971db18d92cb6e7a1b3875a2aee SHA512 bad80555c737f15ce8f3ac097b853a74bcb7b099991b135262492e821a6bcd0e6f647565f49a1eb320fffda7fd5a182b255f45c5cfb4714f2048fecd24a0bc23
+MISC metadata.xml 342 BLAKE2B 1aa7d32650b393da1bfad419c6f65c3d9956db2499d892644612e493a0a992965bdad905f84aee02344bdf563c2013caece8ef34004a0e2dee5d71f8ef3d0739 SHA512 0c99c243d5fe5177581b406fbaf9414b2a96647379dcf81c1ccf89762c300e6b5090ac7ed25e214e5a2ebbae84abdc369a19a37a67d0075aa54228dc71748eca
diff --git a/dev-ruby/git/git-1.3.0.ebuild b/dev-ruby/git/git-1.3.0.ebuild
new file mode 100644
index 000000000000..2f606296e954
--- /dev/null
+++ b/dev-ruby/git/git-1.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+RUBY_FAKEGEM_GEMSPEC="git.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for using Git in Ruby"
+HOMEPAGE="https://github.com/schacon/ruby-git"
+SRC_URI="https://github.com/schacon/ruby-git/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-git-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+DEPEND+="test? ( >=dev-vcs/git-1.6.0.0 app-arch/tar )"
+RDEPEND+=">=dev-vcs/git-1.6.0.0"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ # Needs test-unit, the test-unit version distributed with ruby20 is
+ # not new enough.
+ sed -i -e '3igem "test-unit"' Rakefile || die
+
+ # Don't use hardcoded /tmp directory.
+ sed -i -e "s:/tmp:${TMPDIR}:" tests/units/test_archive.rb tests/test_helper.rb || die
+}
diff --git a/dev-ruby/git/git-1.4.0.ebuild b/dev-ruby/git/git-1.4.0.ebuild
new file mode 100644
index 000000000000..157b12a8f86b
--- /dev/null
+++ b/dev-ruby/git/git-1.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+RUBY_FAKEGEM_GEMSPEC="git.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for using Git in Ruby"
+HOMEPAGE="https://github.com/schacon/ruby-git"
+SRC_URI="https://github.com/schacon/ruby-git/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-git-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+DEPEND+="test? ( >=dev-vcs/git-1.6.0.0 app-arch/tar )"
+RDEPEND+=">=dev-vcs/git-1.6.0.0"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ # Don't use hardcoded /tmp directory.
+ sed -i -e "s:/tmp:${TMPDIR}:" tests/units/test_archive.rb tests/test_helper.rb || die
+}
diff --git a/dev-ruby/git/metadata.xml b/dev-ruby/git/metadata.xml
new file mode 100644
index 000000000000..fe258fd2c3c1
--- /dev/null
+++ b/dev-ruby/git/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">schacon/ruby-git</remote-id>
+ </upstream>
+</pkgmetadata>