summaryrefslogtreecommitdiff
path: root/dev-ruby/git
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
commit4df3bf9762850b34cd1ead5c80374d1a0fc3362e (patch)
tree3080c5cb7ad17abcb63776a9f21c4947845546a6 /dev-ruby/git
parent814f4cf860e299a046b649eaee5463427984c09c (diff)
gentoo resync : 12.07.2021
Diffstat (limited to 'dev-ruby/git')
-rw-r--r--dev-ruby/git/Manifest2
-rw-r--r--dev-ruby/git/git-1.9.1.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/git/Manifest b/dev-ruby/git/Manifest
index ac5d5e00c33b..559715414648 100644
--- a/dev-ruby/git/Manifest
+++ b/dev-ruby/git/Manifest
@@ -1,3 +1,5 @@
DIST git-1.7.0.tar.gz 142017 BLAKE2B cb05ef711582b98b420c143dce8fcc3d932c7509ab8c5577a46d70f180ee37d865d7268f56c133d3327ed27058a4c5cd7b03a6c602c665d2f574bdec476c6eec SHA512 c90cd3fe46767a4db5391eb85534e3801f1bd2f345a324ee89d3c04c4348aef09a5424760c59a079d51f3fa003c3b31d30907bfcff4b854adf3b96339d25a8a0
+DIST git-1.9.1.tar.gz 206509 BLAKE2B 3f8739286f3197fa86a3fccfab357510d562415f568726126cf96c8b74c716c4fbb592f854cafda26cf2f0371e4bc9b52a9f5efdea860d0ea6836198ca48b887 SHA512 ee1df3e704b8bf0687c9fce83d73502d3d46e7f3291da90906961dda057d8e6ec3a0fda5b68c258dd8542559055f1bfabf8915a7e594edafa4b3f267f302f397
EBUILD git-1.7.0.ebuild 879 BLAKE2B 60c6e55cb242a941c55c295f9c5fb4a360f9921e7923f1e930a7c29b685f377668fd6d78b6c0c4885b8aaf5e0e1700885499bcc3011a89641570d81b89b4e8f3 SHA512 4ee521b7a3172180d4d046f0c4f422e0bfbc50a45e5049d344f67ff28c684d0e3e3e1c45e049ee3b1b290531dcac09f7a9e5af38955c672d87fdc72147134242
+EBUILD git-1.9.1.ebuild 1269 BLAKE2B 20ebac905c23a3e7711dc15b5ae9207ccde3151d9877bfa2cb63d103ebc64afe2f97772d574ecb6f2b4b30f058a2a038f564e0d7c67963f558465b10cc85da6e SHA512 ea10a189abe5250b36043c02d7f33067ef34ed2b994e7ab393d2b7325054c36ee805e09d6da8d20637b3e182c67610987013011a55917c90c28021b539e3525b
MISC metadata.xml 342 BLAKE2B 1aa7d32650b393da1bfad419c6f65c3d9956db2499d892644612e493a0a992965bdad905f84aee02344bdf563c2013caece8ef34004a0e2dee5d71f8ef3d0739 SHA512 0c99c243d5fe5177581b406fbaf9414b2a96647379dcf81c1ccf89762c300e6b5090ac7ed25e214e5a2ebbae84abdc369a19a37a67d0075aa54228dc71748eca
diff --git a/dev-ruby/git/git-1.9.1.ebuild b/dev-ruby/git/git-1.9.1.ebuild
new file mode 100644
index 000000000000..bf7218a9f551
--- /dev/null
+++ b/dev-ruby/git/git-1.9.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="git.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for using Git in Ruby"
+HOMEPAGE="https://github.com/schacon/ruby-git"
+SRC_URI="https://github.com/schacon/ruby-git/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-git-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+DEPEND+="test? ( >=dev-vcs/git-1.6.0.0 app-arch/tar )"
+RDEPEND+=">=dev-vcs/git-1.6.0.0"
+
+ruby_add_rdepend ">=dev-ruby/rchardet-1.8:1"
+
+ruby_add_bdepend "test? ( dev-ruby/bundler dev-ruby/minitar dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ # Don't use hardcoded /tmp directory.
+ sed -i -e "s:/tmp:${TMPDIR}:" tests/units/test_archive.rb tests/test_helper.rb || die
+ sed -i -e "1irequire 'pathname'" tests/test_helper.rb || die
+
+ sed -i -e 's/__dir__/"."/' -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ git config --global user.email "git@example.com" || die
+ git config --global user.name "GitExample" || die
+ ${RUBY} -Ilib:.:test -e 'Dir["tests/**/test_*.rb"].each {|f| require f}' || die
+}