summaryrefslogtreecommitdiff
path: root/dev-ruby/gh/gh-0.18.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /dev-ruby/gh/gh-0.18.0.ebuild
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'dev-ruby/gh/gh-0.18.0.ebuild')
-rw-r--r--dev-ruby/gh/gh-0.18.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/gh/gh-0.18.0.ebuild b/dev-ruby/gh/gh-0.18.0.ebuild
new file mode 100644
index 000000000000..8bdd3083a66c
--- /dev/null
+++ b/dev-ruby/gh/gh-0.18.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="gh.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="multi-layer client for the github api v3"
+HOMEPAGE="https://github.com/travis-ci/gh"
+SRC_URI="https://github.com/travis-ci/gh/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "
+ dev-ruby/webmock
+"
+
+ruby_add_rdepend "
+ dev-ruby/activesupport:5.2
+ >=dev-ruby/addressable-2.4.0:0
+ dev-ruby/faraday:1
+ dev-ruby/faraday_middleware:1
+ >dev-ruby/multi_json-1.0
+ dev-ruby/net-http-pipeline
+ >=dev-ruby/net-http-persistent-2.9:*
+"
+
+all_ruby_prepare() {
+ sed -i \
+ -e '/net-http-persistent/ s/~> 2.9/>= 2.9/' \
+ -e 's/git ls-files/find/' \
+ "${RUBY_FAKEGEM_GEMSPEC}" || die
+}