summaryrefslogtreecommitdiff
path: root/dev-ruby/ffi-compiler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-23 03:49:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-23 03:49:35 +0100
commit850d399c4f1568d3c6d013d7f4e2e371c0118bd6 (patch)
tree37fe91f80d4b072d27976558c05df3503c196e85 /dev-ruby/ffi-compiler
parent7b77dd2858b06e4a9367ca16d4c24aacb119b142 (diff)
gentoo auto-resync : 23:10:2022 - 03:49:35
Diffstat (limited to 'dev-ruby/ffi-compiler')
-rw-r--r--dev-ruby/ffi-compiler/Manifest2
-rw-r--r--dev-ruby/ffi-compiler/ffi-compiler-1.0.1-r2.ebuild22
-rw-r--r--dev-ruby/ffi-compiler/files/respect-cflags.patch17
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/ffi-compiler/Manifest b/dev-ruby/ffi-compiler/Manifest
index 11e72f274646..52b78be20f59 100644
--- a/dev-ruby/ffi-compiler/Manifest
+++ b/dev-ruby/ffi-compiler/Manifest
@@ -1,3 +1,5 @@
+AUX respect-cflags.patch 682 BLAKE2B 2e3e90026961257737878e7a0b3b3d1d1d522ee4bbf12e5eed7d8fd61f49a84a7a8eaa83ffb8299d711e4d36b2aa60a9b5078fd83a0d88c689d81212d8902458 SHA512 b0f6593609237a637f78ca8128f48f5bcbb2d2637419bedda532ae8ef8d93a7e4e647e63277a9438d2f4aff9fe430176414fbc5f590fab7b1a452c1be79028a3
DIST ffi-compiler-1.0.1.gem 18432 BLAKE2B 9832d9836a0b55d3099085b53e0c8e15cc5ae79cfadadea942603ef8595b5fa4d781b5f031f0592b2688acb1416acffa9e525e3cbc004c2c51aaaea12a722706 SHA512 7a13625ab1c5748d05ec93d68708dd9435ec92dcd0c823109c44173fdaf8710aec5f5b4fb11966475f10ae91401c7ca3c620f9d36bb9ca665114e1ed70f4edd0
EBUILD ffi-compiler-1.0.1-r1.ebuild 476 BLAKE2B 74c38026898f17915585aafa81155e24cd6e93a63cd8507e86bef7ef4c01403b44035e3e4e9569110a8ae91064806095047e472fb949e81ea8f670cff95a5ea5 SHA512 05c6d8ebb4d016456840bb2366d7c5ccc65d3e8e26ee5a54a43e2f4f2e6220ec6bd53b2055b0b306446decec688f987fdd8ff1a966dc9684a16483d29df62139
+EBUILD ffi-compiler-1.0.1-r2.ebuild 525 BLAKE2B 357abb4b17e3f99bd52a65c65ae136115d94cda34869c43f03725885863adf4107d661380e683d0792405cc44e7c8f05cae99c96d36f1182b6da21526b7e3edf SHA512 e737551cf5a88bb4f5bc5b02e12f360cf137870a98a2bb3f3cecf9deb1cdcee5355d1d84ef01cfd8f4c3a9aafc529cd1e7121bde651e292bbc60c5c58fb93919
MISC metadata.xml 258 BLAKE2B 3c49249352f2cb11df010da6ecd8312a27047557ca5f2686837ad66933be9ea2627c40f91daedf8dcd9099c6cdc0dc2d2ba32aaf9d888c41fb60ee098e1c0c1e SHA512 ce517e35f3c0a2a9807ee68b0a8c84ca28db8dfabb41758cac71f9da22847fe20d259295f0681e38a52a24618450a0ca097939dc1022e3987bb0088762e48326
diff --git a/dev-ruby/ffi-compiler/ffi-compiler-1.0.1-r2.ebuild b/dev-ruby/ffi-compiler/ffi-compiler-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..6a6262edb1ff
--- /dev/null
+++ b/dev-ruby/ffi-compiler/ffi-compiler-1.0.1-r2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby FFI Rakefile generator"
+HOMEPAGE="https://github.com/ffi/ffi/wiki"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86"
+IUSE=""
+# PATCHES=( "${FILESDIR}/respect-cflags.patch" )
+
+ruby_add_rdepend "dev-ruby/rake >=dev-ruby/ffi-1.0.0"
diff --git a/dev-ruby/ffi-compiler/files/respect-cflags.patch b/dev-ruby/ffi-compiler/files/respect-cflags.patch
new file mode 100644
index 000000000000..3fe68f8211cb
--- /dev/null
+++ b/dev-ruby/ffi-compiler/files/respect-cflags.patch
@@ -0,0 +1,17 @@
+diff --git a/lib/ffi-compiler/compile_task.rb b/lib/ffi-compiler/compile_task.rb
+index 363c247..637fd3d 100644
+--- a/lib/ffi-compiler/compile_task.rb
++++ b/lib/ffi-compiler/compile_task.rb
+@@ -26,9 +26,9 @@ module FFI
+ @libraries = []
+ @headers = []
+ @functions = []
+- @cflags = DEFAULT_CFLAGS.dup
+- @cxxflags = DEFAULT_CFLAGS.dup
+- @ldflags = DEFAULT_LDFLAGS.dup
++ @cflags = ENV['CFLAGS']&.split || DEFAULT_CFLAGS.dup
++ @cxxflags = ENV['CXXFLAGS']&.split || DEFAULT_CFLAGS.dup
++ @ldflags = ENV['LDFLAGS']&.split || DEFAULT_LDFLAGS.dup
+ @libs = []
+ @platform = Platform.system
+ @exports = []