summaryrefslogtreecommitdiff
path: root/dev-ruby/ffi-compiler/ffi-compiler-1.3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-06 00:30:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-06 00:30:33 +0100
commit9323524b4d44f4ec3dc923bd8e9ea04bdde8a067 (patch)
tree8ca7b8c58d4e70389d5d4672ebd86cb475cf9f80 /dev-ruby/ffi-compiler/ffi-compiler-1.3.2.ebuild
parent8c11cf748cc296d6338a189106a8cc9e3a1e0948 (diff)
gentoo auto-resync : 06:04:2024 - 00:30:33
Diffstat (limited to 'dev-ruby/ffi-compiler/ffi-compiler-1.3.2.ebuild')
-rw-r--r--dev-ruby/ffi-compiler/ffi-compiler-1.3.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/ffi-compiler/ffi-compiler-1.3.2.ebuild b/dev-ruby/ffi-compiler/ffi-compiler-1.3.2.ebuild
new file mode 100644
index 000000000000..d0a6033acc30
--- /dev/null
+++ b/dev-ruby/ffi-compiler/ffi-compiler-1.3.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby FFI Rakefile generator"
+HOMEPAGE="https://github.com/ffi/ffi/wiki"
+SRC_URI="https://github.com/ffi/ffi-compiler/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+ruby_add_rdepend "dev-ruby/rake >=dev-ruby/ffi-1.15.5"
+
+all_ruby_prepare() {
+ sed -e "s:_relative ':'./:" \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}