summaryrefslogtreecommitdiff
path: root/dev-ruby/fattr/fattr-2.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/fattr/fattr-2.3.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/fattr/fattr-2.3.0.ebuild')
-rw-r--r--dev-ruby/fattr/fattr-2.3.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/fattr/fattr-2.3.0.ebuild b/dev-ruby/fattr/fattr-2.3.0.ebuild
new file mode 100644
index 000000000000..dd702ee80c1b
--- /dev/null
+++ b/dev-ruby/fattr/fattr-2.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="fattr.rb is a \"fatter attr\" for ruby"
+HOMEPAGE="https://github.com/ahoward/fattr"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="test"
+
+each_ruby_test() {
+ ${RUBY} test/fattr_test.rb || die "Tests failed."
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r samples
+}