summaryrefslogtreecommitdiff
path: root/dev-ruby/fast_gettext
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/fast_gettext
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/fast_gettext')
-rw-r--r--dev-ruby/fast_gettext/Manifest5
-rw-r--r--dev-ruby/fast_gettext/fast_gettext-1.6.0.ebuild55
-rw-r--r--dev-ruby/fast_gettext/fast_gettext-1.7.0.ebuild55
-rw-r--r--dev-ruby/fast_gettext/metadata.xml11
4 files changed, 126 insertions, 0 deletions
diff --git a/dev-ruby/fast_gettext/Manifest b/dev-ruby/fast_gettext/Manifest
new file mode 100644
index 000000000000..64799172fb0f
--- /dev/null
+++ b/dev-ruby/fast_gettext/Manifest
@@ -0,0 +1,5 @@
+DIST fast_gettext-1.6.0.tar.gz 88780 BLAKE2B 237a37bf505fe7520a25c6014f0524201905f8cf112624370477229db2d06f7160bad62e42878688ef954a1b72166e21a7f3a89de66c21aec780749fb26cd8bb SHA512 0f26cf8bd8a2078631d32be14fb6bd194dc9bd8a6727a355f4d2978441c972785747063ec4d8b8b1d4c78f07914a8b6cccf37ed85a37e7833bfe724d1d159ae9
+DIST fast_gettext-1.7.0.tar.gz 89176 BLAKE2B a42f50570c65ecf229dab0e29ad40ed3fd0f431f59fcc7daff4ad564131751e8a9884d52dfb8f2edd87b6fd5d1267973225fb51f9256844b37c28b251d15d757 SHA512 83c66c4f7bce6ccc08c1fe9e2b3cb71ea751d68bbff36587039a0b7af7e6276cb481debd3668673822455b9805114531547b28a777cafa8bda0f204ba36bf5a9
+EBUILD fast_gettext-1.6.0.ebuild 1999 BLAKE2B d56cb283287f37612c2b166b76d31acfd8774968664ab1f107c76e3e32310c6f15119d1357e58a562cd8d3c893e30abb564f97ee2ea846d8a7aedf464fe604d2 SHA512 d760902688d8dfc33a4c26a94e889c3135d17049291fdd1dbf660b5ec8d88f5396a3b7459317d0b9c7dfff7292e714ca95d41856e55cf8202ddd0c85e6700842
+EBUILD fast_gettext-1.7.0.ebuild 2001 BLAKE2B 78abdc2e9de11ae3e6827df900ca25b483180dda5e2115e8da27cc4ef4649f88820c6e383783030678ff2cc94b2827e798ff8f457f9521ac823b34c143bafa13 SHA512 55605c23f802ba1debb8523800a23e5fe125d14f47d63f649a9dff23a62bd8f404458b47e2985a0c76027d949dbed61ac66592768b1d2d91422dee3051180dd0
+MISC metadata.xml 346 BLAKE2B 93a39aacb63cc0db79f126c108547c24dd182711584ef61c481b762a35f96cbee330ee29baea8d063e6f2ea2fc0491e572b860156f14be164ab29131a8f047a2 SHA512 1b57982213ae99ae1dc5ea06240bf81f7719f3cc576926de6a0d308f26895236eaa9b3312157eb5af3e47893787c9260e4386988a6f156c9a8b660aae85007ce
diff --git a/dev-ruby/fast_gettext/fast_gettext-1.6.0.ebuild b/dev-ruby/fast_gettext/fast_gettext-1.6.0.ebuild
new file mode 100644
index 000000000000..cdea88d1f547
--- /dev/null
+++ b/dev-ruby/fast_gettext/fast_gettext-1.6.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG Readme.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="GetText but 3.5x faster, 560x less memory, clean namespace and threadsave!"
+HOMEPAGE="https://github.com/grosser/fast_gettext"
+SRC_URI="https://github.com/grosser/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/bundler )"
+
+all_ruby_prepare() {
+ rm Gemfile.lock || die
+
+ # Remove jeweler and bump from Gemfile since they are not needed for tests.
+ sed -i -e '/jeweler/d' -e '/bump/d' -e '/appraisal/d' Gemfile || die
+
+ # Avoid unneeded dependency on git and development dependencies.
+ sed -e '/git ls-files/ s:^:#:' \
+ -e '/\(wwtd\|bump\|sqlite3\|activerecord\|i18n\)/ s:^:#:' \
+ -i fast_gettext.gemspec || die
+
+ # Avoid a test dependency on activerecord since this is now in the
+ # dependency tree for app-admin/puppet and many arches don't have
+ # rails keyworded.
+ sed -i -e '/active_record/ s:^:#:' spec/spec_helper.rb || die
+ rm -f spec/fast_gettext/translation_repository/db_spec.rb || die
+ sed -i -e '/works with DB repository/,/^ end/ s:^:#:' spec/fast_gettext/storage_spec.rb || die
+ sed -i -e '/with i18n loaded/,/^ end/ s:^:#:' spec/fast_gettext/vendor/string_spec.rb || die
+
+ # Don't run a test that requires safe mode which we can't provide
+ # due to insecure directory settings for the portage dir. This spec
+ # also calls out to ruby which won't work with different ruby
+ # implementations.
+ sed -i -e '/can work in SAFE mode/,/^ end/ s:^:#:' spec/fast_gettext/translation_repository/mo_spec.rb || die
+}
+
+each_ruby_prepare() {
+ # Make sure the right ruby interpreter is used
+ sed -i -e "s:bundle exec ruby:bundle exec ${RUBY}:" spec/fast_gettext/vendor/*spec.rb || die
+}
diff --git a/dev-ruby/fast_gettext/fast_gettext-1.7.0.ebuild b/dev-ruby/fast_gettext/fast_gettext-1.7.0.ebuild
new file mode 100644
index 000000000000..97967bdb5e89
--- /dev/null
+++ b/dev-ruby/fast_gettext/fast_gettext-1.7.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG Readme.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="GetText but 3.5x faster, 560x less memory, clean namespace and threadsave!"
+HOMEPAGE="https://github.com/grosser/fast_gettext"
+SRC_URI="https://github.com/grosser/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/bundler )"
+
+all_ruby_prepare() {
+ rm Gemfile.lock || die
+
+ # Remove jeweler and bump from Gemfile since they are not needed for tests.
+ sed -i -e '/jeweler/d' -e '/bump/d' -e '/appraisal/d' Gemfile || die
+
+ # Avoid unneeded dependency on git and development dependencies.
+ sed -e '/git ls-files/ s:^:#:' \
+ -e '/\(wwtd\|bump\|sqlite3\|activerecord\|i18n\)/ s:^:#:' \
+ -i fast_gettext.gemspec || die
+
+ # Avoid a test dependency on activerecord since this is now in the
+ # dependency tree for app-admin/puppet and many arches don't have
+ # rails keyworded.
+ sed -i -e '/active_record/ s:^:#:' spec/spec_helper.rb || die
+ rm -f spec/fast_gettext/translation_repository/db_spec.rb || die
+ sed -i -e '/works with DB repository/,/^ end/ s:^:#:' spec/fast_gettext/storage_spec.rb || die
+ sed -i -e '/with i18n loaded/,/^ end/ s:^:#:' spec/fast_gettext/vendor/string_spec.rb || die
+
+ # Don't run a test that requires safe mode which we can't provide
+ # due to insecure directory settings for the portage dir. This spec
+ # also calls out to ruby which won't work with different ruby
+ # implementations.
+ sed -i -e '/can work in SAFE mode/,/^ end/ s:^:#:' spec/fast_gettext/translation_repository/mo_spec.rb || die
+}
+
+each_ruby_prepare() {
+ # Make sure the right ruby interpreter is used
+ sed -i -e "s:bundle exec ruby:bundle exec ${RUBY}:" spec/fast_gettext/vendor/*spec.rb || die
+}
diff --git a/dev-ruby/fast_gettext/metadata.xml b/dev-ruby/fast_gettext/metadata.xml
new file mode 100644
index 000000000000..5d35b8ec49d4
--- /dev/null
+++ b/dev-ruby/fast_gettext/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">grosser/fast_gettext</remote-id>
+ </upstream>
+</pkgmetadata>