summaryrefslogtreecommitdiff
path: root/dev-ruby/faraday-httpclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-04 07:58:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-04 07:58:30 +0000
commit5e0583283abb5e0f998830cea3f4f9785699b2ed (patch)
treec9999a88a0ae4409d0f85dc733d2b42181f94a53 /dev-ruby/faraday-httpclient
parentfa3c4c282d03b85eb600bae6ec57b619004feb5a (diff)
gentoo auto-resync : 04:01:2024 - 07:58:30
Diffstat (limited to 'dev-ruby/faraday-httpclient')
-rw-r--r--dev-ruby/faraday-httpclient/Manifest3
-rw-r--r--dev-ruby/faraday-httpclient/faraday-httpclient-1.0.1.ebuild32
-rw-r--r--dev-ruby/faraday-httpclient/metadata.xml11
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/faraday-httpclient/Manifest b/dev-ruby/faraday-httpclient/Manifest
new file mode 100644
index 000000000000..ff676419b60d
--- /dev/null
+++ b/dev-ruby/faraday-httpclient/Manifest
@@ -0,0 +1,3 @@
+DIST faraday-httpclient-1.0.1.tar.gz 8438 BLAKE2B eb642d2d69b3daeca9763df86399b1e76f2d3e84cec19218ff0c486f547594f83f30a776b0be95e5f4f976505e5a4299eec3ded9652ee61ceace63b29260d47f SHA512 440d57cad24bd7f52c4b1ea8f8062a62630791f8a5730999aa41ece5b0c759a188afbb8449e32eea03710bfc7bffbe244664d305f41457e88791f916ef142d86
+EBUILD faraday-httpclient-1.0.1.ebuild 797 BLAKE2B 02844e4908c20068d5b78e69a9ff70e2405676c11b3cda42a4d9cdcd291c592d7ff41c69933a3f420148716da92728c73ff29b0178a6f5db20ec5676edd246e9 SHA512 75382ef7ddad4e6f284fb89bb3e9d17792f7cd0c685c39195b6d698af22eed5e9a77ee626baf2cd2e756fe943a3d2ba460d8c7b61041a44da6542585090a3aeb
+MISC metadata.xml 356 BLAKE2B af62c68b3311306aec419744d29f6894a1d7cfe0df0477ababca9c8c1c03254657bd98b428f9a9f81549bce081674e2ec1652483e10343b77d09f1ea448b0daa SHA512 26e8dc2c6b448ee3e6a335c9d9afd29525321e1dda82279d431ae273705592fe40d059c392a64b105bbdb246a455dcb477b5d3d3d01250070ba1656384316d64
diff --git a/dev-ruby/faraday-httpclient/faraday-httpclient-1.0.1.ebuild b/dev-ruby/faraday-httpclient/faraday-httpclient-1.0.1.ebuild
new file mode 100644
index 000000000000..0786be91d30d
--- /dev/null
+++ b/dev-ruby/faraday-httpclient/faraday-httpclient-1.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Faraday adapter for HTTPClient"
+HOMEPAGE="https://github.com/lostisland/faraday-httpclient"
+SRC_URI="https://github.com/lostisland/faraday-httpclient/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/faraday:1 dev-ruby/httpclient )"
+
+all_ruby_prepare() {
+ sed -i -e "s:_relative ':'./:" ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -i -e '2igem "faraday", "~> 1.0"' spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/faraday-httpclient/metadata.xml b/dev-ruby/faraday-httpclient/metadata.xml
new file mode 100644
index 000000000000..5450cd18f3de
--- /dev/null
+++ b/dev-ruby/faraday-httpclient/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lostisland/faraday-httpclient</remote-id>
+ </upstream>
+</pkgmetadata>