summaryrefslogtreecommitdiff
path: root/dev-ruby/eventmachine
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/eventmachine
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/eventmachine')
-rw-r--r--dev-ruby/eventmachine/Manifest5
-rw-r--r--dev-ruby/eventmachine/eventmachine-1.2.0.1.ebuild88
-rw-r--r--dev-ruby/eventmachine/eventmachine-1.2.7.ebuild92
-rw-r--r--dev-ruby/eventmachine/metadata.xml11
4 files changed, 196 insertions, 0 deletions
diff --git a/dev-ruby/eventmachine/Manifest b/dev-ruby/eventmachine/Manifest
new file mode 100644
index 000000000000..a8a8e6913b1b
--- /dev/null
+++ b/dev-ruby/eventmachine/Manifest
@@ -0,0 +1,5 @@
+DIST eventmachine-1.2.0.1.gem 241152 BLAKE2B f7df9888ba9f3ef731099124ce7cf2b6b396f57dc948feb828f015f2b33426348c87f2443fc6f678e94550167241c2ae154f3679b13b3b7e1bdb6bcdae6cfaab SHA512 a861a2c5172b7cf2720bdb54f52ea96c311c10efdb2f54970054901674e044a72307a5b32210efbbdb78d0472a9b3fb6e898640e1c0b406bdad8b581970e30aa
+DIST eventmachine-1.2.7.tar.gz 246402 BLAKE2B 3eee1e5fbb367c03e3d801cb705a0f95b7bbb461885f04820f57421019a3d61eecabe71309981eec35168395eb6d98a8c675bd0fb225497de511f2ce09a5df92 SHA512 768ec084903dce4c737cf564fce7886a3e7e5b7d4a89c2baea3e998130c53dc00488eaa2d8e9b0133d9e4d8fffbde80c3025403881486a7968c2d84425cc1f50
+EBUILD eventmachine-1.2.0.1.ebuild 2774 BLAKE2B 49a46edecc1b6da43cf90d5da669818ecef2722450f5245651976421ba5c0ea77db4a7269df8c66d35ec780be4acdda49add7a0fdc6aff06fde47e6a5de08bb8 SHA512 9f8132929ec7ef0b4c121d0456baf88dcd3943aafda51cbeb5fb5214ddaa01423022250ed6aae6194358cd2215d1c51f3f1e3ee20034f63d86d890130ffd63b9
+EBUILD eventmachine-1.2.7.ebuild 2811 BLAKE2B 4b132e0712a7bd8e50bc5c4a0fe35cf8b0b8bcdf49b65a9df52deaf4525c59d76da04da429fda97360781a0da817dbf6fab84c27a999189246a09e48bcec9bad SHA512 e04154068c33c09281c662095046df7ebbf61f01548dc74d0605090c33eb09d4d1c6be2c82f7e9bfd576a8903d5453dde1a172c8161621f4888f56860da84216
+MISC metadata.xml 523 BLAKE2B c8c4dc99c1560b2dc7233a194f0892bf86397594daf3896408d080632dda52cae3fef16654e2a35340bc0746befab669071ff9de7707fcbd92583472aa52f73d SHA512 622ac8cdd832ad49db828fefc3c9ab089e1d7e3795e369778591b4f572a647a99d4625fb9a3624189d0521a8daa9d2360bfe01fd905e8d106b83e244d900e509
diff --git a/dev-ruby/eventmachine/eventmachine-1.2.0.1.ebuild b/dev-ruby/eventmachine/eventmachine-1.2.0.1.ebuild
new file mode 100644
index 000000000000..600e79ac5697
--- /dev/null
+++ b/dev-ruby/eventmachine/eventmachine-1.2.0.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="docs/*.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="EventMachine is a fast, simple event-processing library for Ruby programs"
+HOMEPAGE="http://rubyeventmachine.com"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="${DEPEND}
+ dev-libs/openssl:0"
+RDEPEND="${RDEPEND}
+ dev-libs/openssl:0"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ # Remove package tasks to avoid dependency on rake-compiler.
+ rm rakelib/package.rake || die
+
+ # fix test issue - upstream b96b736b39261f7d74f013633cc7cd619afa20c4
+ sed -i -e 's/DEBUG/BROADCAST/g' tests/test_set_sock_opt.rb || die
+ sed -i -e "/omit_/d" tests/test_*.rb || die
+ # Remove the resolver tests since they require network access and
+ # the localhost test fails with an IPv6 localhost.
+ rm tests/test_resolver.rb || die
+ # Needs a tty
+ rm tests/test_kb.rb || die
+ # Avoid tests that require network access
+ sed -i -e '/test_bind_connect/,/^ end/ s:^:#:' \
+ tests/test_basic.rb || die
+ sed -i -e '/test_\(cookie\|http_client\|version_1_0\)/,/^ end/ s:^:#:' \
+ tests/test_httpclient.rb || die
+ sed -i -e '/test_\(get\|https_get\)/,/^ end/ s:^:#:' \
+ tests/test_httpclient2.rb || die
+ sed -i -e '/test_connect_timeout/,/^ end/ s:^:#:' \
+ tests/test_unbind_reason.rb || die
+ sed -i -e '/test_for_real/,/^ end/ s:^:#:' \
+ tests/test_pending_connect_timeout.rb || die
+ rm -f tests/test_{get_sock_opt,set_sock_opt,idle_connection}.rb || die
+ sed -i -e '/test_ipv6_tcp_client_with_ipv6_google_com/aomit "network"' tests/test_ipv6.rb || die
+ # don't test unsecure and obsolete protocols
+ sed -i -e 's/sslv2 sslv3//' \
+ -e '/\(test_any_to_v3\|test_v3_to_any\|test_v3_to_v3\|test_v3_with_external\)/aomit "obsolete"' \
+ tests/test_ssl_protocols.rb || die
+
+}
+
+each_ruby_configure() {
+ for extdir in ext ext/fastfilereader; do
+ pushd $extdir
+ ${RUBY} extconf.rb || die "extconf.rb failed for ${extdir}"
+ popd
+ done
+}
+
+each_ruby_compile() {
+ for extdir in ext ext/fastfilereader; do
+ pushd $extdir
+ # both extensions use C++, so use the CXXFLAGS not the CFLAGS
+ emake V=1 CFLAGS="${CXXFLAGS} -fPIC" archflag="${LDFLAGS}" || die "emake failed for ${extdir}"
+ popd
+ cp $extdir/*.so lib/ || die "Unable to copy extensions for ${extdir}"
+ done
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb-2 tests/test_*.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/
+ doins -r examples || die "Failed to install examples"
+}
diff --git a/dev-ruby/eventmachine/eventmachine-1.2.7.ebuild b/dev-ruby/eventmachine/eventmachine-1.2.7.ebuild
new file mode 100644
index 000000000000..68b8c3ce8508
--- /dev/null
+++ b/dev-ruby/eventmachine/eventmachine-1.2.7.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="docs/*.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="EventMachine is a fast, simple event-processing library for Ruby programs"
+HOMEPAGE="http://rubyeventmachine.com"
+SRC_URI="https://github.com/eventmachine/eventmachine/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="${DEPEND}
+ dev-libs/openssl:0"
+RDEPEND="${RDEPEND}
+ dev-libs/openssl:0"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ # Remove package tasks to avoid dependency on rake-compiler.
+ rm rakelib/package.rake || die
+
+ # Remove the resolver tests since they require network access and
+ # the localhost test fails with an IPv6 localhost.
+ rm tests/test_resolver.rb || die
+
+ # Needs a tty
+ rm tests/test_kb.rb || die
+
+ # Avoid tests that require network access
+ sed -i -e '/test_bind_connect/,/^ end/ s:^:#:' \
+ tests/test_basic.rb || die
+ sed -i -e '/test_\(cookie\|http_client\|version_1_0\)/,/^ end/ s:^:#:' \
+ tests/test_httpclient.rb || die
+ sed -i -e '/test_\(get\|https_get\)/,/^ end/ s:^:#:' \
+ tests/test_httpclient2.rb || die
+ sed -i -e '/test_connect_timeout/,/^ end/ s:^:#:' \
+ tests/test_unbind_reason.rb || die
+ sed -i -e '/test_for_real/,/^ end/ s:^:#:' \
+ tests/test_pending_connect_timeout.rb || die
+ rm -f tests/test_{get_sock_opt,set_sock_opt,idle_connection}.rb || die
+
+ # Avoid tests for insecure SSL versions that may not be available
+ sed -i -e '/test_any_to_v3/,/^ end/ s:^:#:' \
+ -e '/test_v3_/,/^ end/ s:^:#:' \
+ -e '/test_tlsv1_required_with_external_client/aomit "sslv3"' \
+ tests/test_ssl_protocols.rb || die
+
+ # Avoid test that deliberately triggers a C++ exception which causes
+ # a SEGFAULT. This does not appear to happen upstream (on travis).
+ rm -f tests/test_exc.rb || die
+}
+
+each_ruby_configure() {
+ for extdir in ext ext/fastfilereader; do
+ pushd $extdir
+ ${RUBY} extconf.rb || die "extconf.rb failed for ${extdir}"
+ popd
+ done
+}
+
+each_ruby_compile() {
+ for extdir in ext ext/fastfilereader; do
+ pushd $extdir
+ # both extensions use C++, so use the CXXFLAGS not the CFLAGS
+ emake V=1 CFLAGS="${CXXFLAGS} -fPIC" archflag="${LDFLAGS}" || die "emake failed for ${extdir}"
+ popd
+ cp $extdir/*.so lib/ || die "Unable to copy extensions for ${extdir}"
+ done
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb-2 tests/test_*.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/
+ doins -r examples || die "Failed to install examples"
+}
diff --git a/dev-ruby/eventmachine/metadata.xml b/dev-ruby/eventmachine/metadata.xml
new file mode 100644
index 000000000000..b61ffaa1744c
--- /dev/null
+++ b/dev-ruby/eventmachine/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+</maintainer>
+<longdescription>
+Ruby/EventMachine is a fast, simple event-processing library for Ruby programs. It lets you write network clients and servers without handling sockets- all you do is send and receive data. Single-threaded socket engine- scalable and FAST!
+</longdescription>
+</pkgmetadata>