summaryrefslogtreecommitdiff
path: root/dev-ruby/ethon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/ethon
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/ethon')
-rw-r--r--dev-ruby/ethon/Manifest3
-rw-r--r--dev-ruby/ethon/ethon-0.11.0.ebuild33
-rw-r--r--dev-ruby/ethon/metadata.xml11
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/ethon/Manifest b/dev-ruby/ethon/Manifest
new file mode 100644
index 000000000000..8b2d05106cef
--- /dev/null
+++ b/dev-ruby/ethon/Manifest
@@ -0,0 +1,3 @@
+DIST ethon-0.11.0.gem 56832 BLAKE2B 64f184e3dbedf6fc05cb97d7e642366b45b9493ccd79ba1dd9f4ddafea695bc8d5e72bc5a305e192ad6f78d55704319316a13ced61c14aef7d3e41936ec69a78 SHA512 271ff2ce5578352722bab318ad40f06d9c76fdbdead573a015fed0a38f3fd6341bcf70acedaa9470fe97f47069977b09ac9f71d8dacb21b67aad917c2a078c72
+EBUILD ethon-0.11.0.ebuild 701 BLAKE2B f5a7ca285a40af9b0bd934b619626d3d1f11b41d29bb60054e77d2875e92c3072d1f23d8fce8c9e1808f22ae8d4f8abadb42b99e899bd1f2ab162aaa12cea387 SHA512 af3b4e23f66c61f621ad30395fa197706d5a0800820c398523b00891fcdb91f97d2bdc7a032aa3bafd6d8a730207648002454f165224d3036aa0757bce2d7166
+MISC metadata.xml 340 BLAKE2B e49ffc5833004b5841c276ab1d712c48f8682d73aaa58e0910aead01698be2aaab88f4cde7ebc0d49ed34d177a3477ecbe99928c1924ddce664e2d4523b06210 SHA512 d6fddbbfe4745ef287bfb946576e68e72f135dd9664ad8add271f0d1724b0da518472a7bb26caeff0d62b5a720a2bff223a33b7488c15f5d09668b66ca40cbe5
diff --git a/dev-ruby/ethon/ethon-0.11.0.ebuild b/dev-ruby/ethon/ethon-0.11.0.ebuild
new file mode 100644
index 000000000000..9f332d857bd9
--- /dev/null
+++ b/dev-ruby/ethon/ethon-0.11.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Very lightweight libcurl wrapper"
+HOMEPAGE="https://github.com/typhoeus/ethon"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND+=" net-misc/curl"
+
+ruby_add_rdepend ">=dev-ruby/ffi-1.3.0"
+
+ruby_add_bdepend "test? ( dev-ruby/sinatra dev-ruby/mime-types )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -e '/bundler/I s:^:#:' \
+ -e '1igem "sinatra"' -i Rakefile spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/ethon/metadata.xml b/dev-ruby/ethon/metadata.xml
new file mode 100644
index 000000000000..20f2a1f8eb97
--- /dev/null
+++ b/dev-ruby/ethon/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">typhoeus/ethon</remote-id>
+ </upstream>
+</pkgmetadata>