summaryrefslogtreecommitdiff
path: root/dev-ruby/ethon/ethon-0.15.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-ruby/ethon/ethon-0.15.0.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-ruby/ethon/ethon-0.15.0.ebuild')
-rw-r--r--dev-ruby/ethon/ethon-0.15.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/ethon/ethon-0.15.0.ebuild b/dev-ruby/ethon/ethon-0.15.0.ebuild
new file mode 100644
index 000000000000..0527c5d42892
--- /dev/null
+++ b/dev-ruby/ethon/ethon-0.15.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Very lightweight libcurl wrapper"
+HOMEPAGE="https://github.com/typhoeus/ethon"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND+=" net-misc/curl"
+
+ruby_add_rdepend ">=dev-ruby/ffi-1.15.0"
+
+ruby_add_bdepend "test? ( dev-ruby/sinatra dev-ruby/mime-types )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -e '/bundler/I s:^:#:' \
+ -e '1igem "sinatra"' -i Rakefile spec/spec_helper.rb || die
+}