summaryrefslogtreecommitdiff
path: root/dev-ruby/erubis/erubis-2.7.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/erubis/erubis-2.7.0-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/erubis/erubis-2.7.0-r2.ebuild')
-rw-r--r--dev-ruby/erubis/erubis-2.7.0-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/erubis/erubis-2.7.0-r2.ebuild b/dev-ruby/erubis/erubis-2.7.0-r2.ebuild
new file mode 100644
index 000000000000..5e31d51fbaaa
--- /dev/null
+++ b/dev-ruby/erubis/erubis-2.7.0-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Erubis is an implementation of eRuby"
+HOMEPAGE="http://www.kuwata-lab.com/erubis/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 ~hppa ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# http://rubyforge.org/tracker/index.php?func=detail&aid=29484&group_id=1320&atid=5201
+# Tests are not compatible with Psych as YAML module.
+RESTRICT="test"
+
+ruby_add_rdepend ">=dev-ruby/abstract-1.0.0"
+
+all_ruby_prepare() {
+ # These tests now fail due to other ordering and fact that sym
+ # are now returned.
+ rm test/test-users-guide.rb || die
+ sed -i -e '/test-users-guide/ s:^:#:' test/test.rb || die
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -I. test/test.rb || die
+}