summaryrefslogtreecommitdiff
path: root/dev-ruby/ed25519/ed25519-1.2.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
commitcb3e8c6af7661fbcafdcacc7e0ecdfb610d098fa (patch)
tree047fc92023c520d07f13ec5ac96e094d1b312a7a /dev-ruby/ed25519/ed25519-1.2.4.ebuild
parent7b9f15840068dfaeea5684f8a1af1fe460dfa14c (diff)
gentoo resync : 09.06.2018
Diffstat (limited to 'dev-ruby/ed25519/ed25519-1.2.4.ebuild')
-rw-r--r--dev-ruby/ed25519/ed25519-1.2.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/ed25519/ed25519-1.2.4.ebuild b/dev-ruby/ed25519/ed25519-1.2.4.ebuild
new file mode 100644
index 000000000000..ad1b52d61a5b
--- /dev/null
+++ b/dev-ruby/ed25519/ed25519-1.2.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for the Ed25519 public-key signature system"
+HOMEPAGE="https://github.com/crypto-rb/ed25519"
+SRC_URI="https://github.com/crypto-rb/ed25519/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/ed25519_ref10 extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/ed25519_ref10
+ cp ext/ed25519_ref10/ed25519_ref10.so lib/ || die
+}