summaryrefslogtreecommitdiff
path: root/dev-ruby/dnsruby
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/dnsruby
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/dnsruby')
-rw-r--r--dev-ruby/dnsruby/Manifest7
-rw-r--r--dev-ruby/dnsruby/dnsruby-1.60.2.ebuild33
-rw-r--r--dev-ruby/dnsruby/dnsruby-1.61.0.ebuild33
-rw-r--r--dev-ruby/dnsruby/dnsruby-1.61.1.ebuild33
-rw-r--r--dev-ruby/dnsruby/metadata.xml14
5 files changed, 120 insertions, 0 deletions
diff --git a/dev-ruby/dnsruby/Manifest b/dev-ruby/dnsruby/Manifest
new file mode 100644
index 000000000000..0c6ab465ca73
--- /dev/null
+++ b/dev-ruby/dnsruby/Manifest
@@ -0,0 +1,7 @@
+DIST dnsruby-1.60.2.gem 254976 BLAKE2B fa91e3994331fcb37650c905fb00cd58363ca9b90a3943934b2bb3de0ac82b9efeda418bba45673ec3911676dd1b68bd47d079c3ded201c190d17e2ee2bef0f4 SHA512 dcf191421aaf667f59baaa8098099c5532542e1b9e4fa6ad63a727361d985f14adb3d3fee4aef78c4b6ef8809fe06447ee60d7a220af93e57848a57e0ddfaa22
+DIST dnsruby-1.61.0.gem 257024 BLAKE2B ba0662b758e8950bf4d9617ee1b36330ba5a66560c8a07985dcd7c41be0881287e4b4de35e009c0319021ba7ebde107f67b3bff0eecbac101ebe32fa0d8b3d97 SHA512 7ea06e40790a822d7eaa604d349acb692103b7dd5faa2b9fce8e3a4bba520d9597e1c6e7c5f74ad64cdcdf2583bce606d444c07b4e52d3ef6630fc7869168015
+DIST dnsruby-1.61.1.gem 257024 BLAKE2B dd5329ec48220b6ddd8b156701b840b1990c12bd1d7d46fcf1fbf62cd86437fa47829fdf95b48aa0d1e2608be524fdb1580019817a96b6ccf7297be490ea97fd SHA512 418dc94931a5a0f8ed136caa29acadf1d45026ab521bf95d0548e7f8122599f405e71a73331921e606542a9178bde99a7ba53aee91459201d73b33f9f0f59b58
+EBUILD dnsruby-1.60.2.ebuild 802 BLAKE2B 66ba1eb5a8a48f3df819d15e0785ba52399a61a1a574b693d80db25e99e0df315d950166a93ad002c381be8b57400255b3eb461dc08344f042f309d7994cdd62 SHA512 4cd705757ee37462f5183542cafa9ffbe5ae8acb0f0c6abef60af4a48c87ccfe96cb8cb8115bb6505ef156e442ae8ef3b6498c8d2b1b28e627d5b0da7a992f86
+EBUILD dnsruby-1.61.0.ebuild 795 BLAKE2B f8e90b4cc2103c0ab1685576405cdc97274439450285c9941bdb894db32989d25df523ad70a6aa907a043d83cc62e5cc44c58d266823d49e16bc2c6d8ce602b9 SHA512 620a80c40b8897e885f21223fa8c14edc596a0253ddf11276a02311ecd4fa080b90fa675f41dd1e22d91de7b1a60dbadb7da9241af048ba9c0227b2a0231e6cf
+EBUILD dnsruby-1.61.1.ebuild 795 BLAKE2B f8e90b4cc2103c0ab1685576405cdc97274439450285c9941bdb894db32989d25df523ad70a6aa907a043d83cc62e5cc44c58d266823d49e16bc2c6d8ce602b9 SHA512 620a80c40b8897e885f21223fa8c14edc596a0253ddf11276a02311ecd4fa080b90fa675f41dd1e22d91de7b1a60dbadb7da9241af048ba9c0227b2a0231e6cf
+MISC metadata.xml 413 BLAKE2B afeb40e610311f15b7a95117ea91507e9cfcc0e26903cab7e58f0af5dfce580dd782e96338a8a6a7573cb3ac12497541c2c3284fac9f35b045d5a26608c5506f SHA512 4badb70d7bfddbd8d242d1b400672691ccf737a329e365321dc403dff791669417ba0b0df62efd1ad1c5946e11a7756b22a2790b171e3629d2d30ebfefc5c0f9
diff --git a/dev-ruby/dnsruby/dnsruby-1.60.2.ebuild b/dev-ruby/dnsruby/dnsruby-1.60.2.ebuild
new file mode 100644
index 000000000000..b2e1dbe2e251
--- /dev/null
+++ b/dev-ruby/dnsruby/dnsruby-1.60.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_DOCDIR="html"
+RUBY_FAKEGEM_EXTRADOC="DNSSEC EXAMPLES README.md"
+inherit ruby-fakegem
+
+DESCRIPTION="A pure Ruby DNS client library"
+HOMEPAGE="https://github.com/alexdalitz/dnsruby"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.4:5 )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Cc]overall/d" Rakefile || die
+ sed -i -e '/display/d' \
+ -e '/Display/,/^}/d' test/spec_helper.rb || die
+}
+
+each_ruby_test() {
+ # only run offline tests
+ #${RUBY} -I .:lib test/ts_dnsruby.rb || die "test failed"
+ ${RUBY} -I .:lib test/ts_offline.rb || die "test failed"
+}
diff --git a/dev-ruby/dnsruby/dnsruby-1.61.0.ebuild b/dev-ruby/dnsruby/dnsruby-1.61.0.ebuild
new file mode 100644
index 000000000000..305d820349e9
--- /dev/null
+++ b/dev-ruby/dnsruby/dnsruby-1.61.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_DOCDIR="html"
+RUBY_FAKEGEM_EXTRADOC="DNSSEC EXAMPLES README.md"
+inherit ruby-fakegem
+
+DESCRIPTION="A pure Ruby DNS client library"
+HOMEPAGE="https://github.com/alexdalitz/dnsruby"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.4:5 )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Cc]overall/d" Rakefile || die
+ sed -i -e '/display/d' \
+ -e '/Display/,/^}/d' test/spec_helper.rb || die
+}
+
+each_ruby_test() {
+ # only run offline tests
+ #${RUBY} -I .:lib test/ts_dnsruby.rb || die "test failed"
+ ${RUBY} -I .:lib test/ts_offline.rb || die "test failed"
+}
diff --git a/dev-ruby/dnsruby/dnsruby-1.61.1.ebuild b/dev-ruby/dnsruby/dnsruby-1.61.1.ebuild
new file mode 100644
index 000000000000..305d820349e9
--- /dev/null
+++ b/dev-ruby/dnsruby/dnsruby-1.61.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_DOCDIR="html"
+RUBY_FAKEGEM_EXTRADOC="DNSSEC EXAMPLES README.md"
+inherit ruby-fakegem
+
+DESCRIPTION="A pure Ruby DNS client library"
+HOMEPAGE="https://github.com/alexdalitz/dnsruby"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.4:5 )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Cc]overall/d" Rakefile || die
+ sed -i -e '/display/d' \
+ -e '/Display/,/^}/d' test/spec_helper.rb || die
+}
+
+each_ruby_test() {
+ # only run offline tests
+ #${RUBY} -I .:lib test/ts_dnsruby.rb || die "test failed"
+ ${RUBY} -I .:lib test/ts_offline.rb || die "test failed"
+}
diff --git a/dev-ruby/dnsruby/metadata.xml b/dev-ruby/dnsruby/metadata.xml
new file mode 100644
index 000000000000..65c64fc3479d
--- /dev/null
+++ b/dev-ruby/dnsruby/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mschiff@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">alexdalitz/dnsruby</remote-id>
+ </upstream>
+</pkgmetadata>