summaryrefslogtreecommitdiff
path: root/dev-ruby/diff-lcs/diff-lcs-1.4.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ruby/diff-lcs/diff-lcs-1.4.4.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ruby/diff-lcs/diff-lcs-1.4.4.ebuild')
-rw-r--r--dev-ruby/diff-lcs/diff-lcs-1.4.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/diff-lcs/diff-lcs-1.4.4.ebuild b/dev-ruby/diff-lcs/diff-lcs-1.4.4.ebuild
new file mode 100644
index 000000000000..febdfbd54d42
--- /dev/null
+++ b/dev-ruby/diff-lcs/diff-lcs-1.4.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Use the McIlroy-Hunt LCS algorithm to compute differences"
+HOMEPAGE="https://github.com/halostatue/diff-lcs"
+
+LICENSE="|| ( MIT Ruby GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ # Avoid specs failing due to missing fixtures. Should be fixed in the next version.
+ rm -f spec/ldiff_spec.rb || die
+}