summaryrefslogtreecommitdiff
path: root/dev-ruby/debug_inspector
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/debug_inspector
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/debug_inspector')
-rw-r--r--dev-ruby/debug_inspector/Manifest3
-rw-r--r--dev-ruby/debug_inspector/debug_inspector-0.0.3.ebuild29
-rw-r--r--dev-ruby/debug_inspector/metadata.xml11
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/debug_inspector/Manifest b/dev-ruby/debug_inspector/Manifest
new file mode 100644
index 000000000000..4c8408646d72
--- /dev/null
+++ b/dev-ruby/debug_inspector/Manifest
@@ -0,0 +1,3 @@
+DIST debug_inspector-0.0.3.gem 8192 BLAKE2B c7605f246519b245d0b997e10cfc1271c6cd5a31dc44097546d51265eb6ce1d88686b1dc922addce0a58b6bccae4fa5a40611942b6babbf8dfc6b4c528949422 SHA512 38cbe0ddf2eb4285f4f7d6f12428747495230425352e1850a4395a5c27ad4c2f706eeeac1f684baea488f6e3bd4b65c8c9e0d5807d5af93d3350fa7b9d45da43
+EBUILD debug_inspector-0.0.3.ebuild 589 BLAKE2B 3628edd90a3c92596095bdef4278ff36f678bb5d55e3cfc2d4cddc69153a565e583c1d472296bc35203e1e4122cf1cf1b1af2c71c939fb475d1cc1f82cd01dea SHA512 d73444ac43b4eee4d3d581eb6b5de1318a29b8dcb117d7c92a87f2931e18c5fdde3cc5897eef59e25398c1afea241acd11aca399fde9433914d6e4a80d19b285
+MISC metadata.xml 350 BLAKE2B 1dd62d682b217a24d9af313c9c81b84408466b076d7e170aa84491520ee7813efbf7f5d6a1bc4c7a86cc7d9196aed3b675a98cc361002807dbf59f96794f4c91 SHA512 032b694988de00daeae365ac600fbfcd4cb9434ae8e43bbfe0b5736346594d3f026e29af7aa87cdf29723d2140cd890d9039c6de1b6f850a162c02f8a7ecaae0
diff --git a/dev-ruby/debug_inspector/debug_inspector-0.0.3.ebuild b/dev-ruby/debug_inspector/debug_inspector-0.0.3.ebuild
new file mode 100644
index 000000000000..1201483ea951
--- /dev/null
+++ b/dev-ruby/debug_inspector/debug_inspector-0.0.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby wrapper for the MRI 2.0 debug_inspector API"
+HOMEPAGE="https://github.com/banister/debug_inspector"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+each_ruby_configure() {
+ ${RUBY} -Cext/${PN} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/${PN}
+ cp ext/${PN}/${PN}.so lib/ || die
+}
diff --git a/dev-ruby/debug_inspector/metadata.xml b/dev-ruby/debug_inspector/metadata.xml
new file mode 100644
index 000000000000..3330955745bc
--- /dev/null
+++ b/dev-ruby/debug_inspector/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">banister/debug_inspector</remote-id>
+ </upstream>
+</pkgmetadata>