summaryrefslogtreecommitdiff
path: root/dev-ruby/ddplugin/ddplugin-1.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/ddplugin/ddplugin-1.0.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/ddplugin/ddplugin-1.0.1.ebuild')
-rw-r--r--dev-ruby/ddplugin/ddplugin-1.0.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/ddplugin/ddplugin-1.0.1.ebuild b/dev-ruby/ddplugin/ddplugin-1.0.1.ebuild
new file mode 100644
index 000000000000..935cab84925e
--- /dev/null
+++ b/dev-ruby/ddplugin/ddplugin-1.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides plugin management for Ruby projects"
+HOMEPAGE="https://github.com/ddfreyne/ddplugin/"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/coverall/I s:^:#:' test/helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}