summaryrefslogtreecommitdiff
path: root/dev-ruby/date_validator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/date_validator
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/date_validator')
-rw-r--r--dev-ruby/date_validator/Manifest3
-rw-r--r--dev-ruby/date_validator/date_validator-0.9.0.ebuild48
-rw-r--r--dev-ruby/date_validator/metadata.xml11
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-ruby/date_validator/Manifest b/dev-ruby/date_validator/Manifest
new file mode 100644
index 000000000000..413c2eec3cb0
--- /dev/null
+++ b/dev-ruby/date_validator/Manifest
@@ -0,0 +1,3 @@
+DIST date_validator-0.9.0.gem 12288 BLAKE2B 1a180a88ce4669a29381fae8c9a2407a9026404d0aa2d7be24566ab1f35dfc4a2c17c0c06556c3388e49198dc6bfc11425c2f899c46bcec8a39d6b284269b4e0 SHA512 da7c06d22375cb5ce0e3a1c7d8c84d03c60f5564329d7a6adca4448d386bd26341786e97e6d74d6c7ba820c4437fe88f6dea1e20312b07714f28557bb863c051
+EBUILD date_validator-0.9.0.ebuild 1007 BLAKE2B 4c66c06b058d0ab659f9c38929c64f38677bb7ab1beb5118f0c4f2ff99d2bfab4e7cce63139b7345bb0c4cc57b910dcaa441ce256be9d0549e5ad607928b01f1 SHA512 a6e5d1cd12fe352a0b1033fd87566dcc2ceb4adf83781e243effb78d50e0050721897133aeaf78e21f71ac8e97d3c207abb7623665bfb984ef1daf1460a75d58
+MISC metadata.xml 349 BLAKE2B 4b120116447656e42f1247065f08006f19da25e019491f904eafeb12ce35bb012f2c0330d8ff219f7c2ac72e4c0423b93a2a3ffee36da1de08454c6306856722 SHA512 67be0f0ac5cc6bae9b3d76a371bcceefc5c32c4a384a02f7f13a0fa1da950ff864a106430922a3aad2d8b5522a216ad6d93eba949ba1bd76f37926abc40fd6c8
diff --git a/dev-ruby/date_validator/date_validator-0.9.0.ebuild b/dev-ruby/date_validator/date_validator-0.9.0.ebuild
new file mode 100644
index 000000000000..2310e0c8eae9
--- /dev/null
+++ b/dev-ruby/date_validator/date_validator-0.9.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_EXTRADOC="Readme.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+# if ever needed
+#GITHUB_USER="codegram"
+#GITHUB_PROJECT="${PN}"
+#RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple, ORM agnostic, Ruby 1.9 compatible date validator for Rails 3"
+HOMEPAGE="https://github.com/codegram/date_validator"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activemodel-3.0:*
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/minitest
+ >=dev-ruby/tzinfo-0.3
+ >=dev-ruby/activesupport-3.0
+ )
+ doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ sed -i \
+ -e '/git ls-files/d' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i \
+ -e '/[Bb]undler/s/^/#/' Rakefile || die
+ # Fix tests
+ sed -i -e "1irequire 'active_support'" test/test_helper.rb || die
+}
diff --git a/dev-ruby/date_validator/metadata.xml b/dev-ruby/date_validator/metadata.xml
new file mode 100644
index 000000000000..004dc1b0332f
--- /dev/null
+++ b/dev-ruby/date_validator/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">codegram/date_validator</remote-id>
+ </upstream>
+</pkgmetadata>